Find the answer to your Linux question:
Results 1 to 2 of 2
I have iptables to log messages at info level (so it's level 6). At first i played with syslogd by tweaking syslog.conf, which in despair led me to edit it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    9

    Unhappy Annoying iptables console logging


    I have iptables to log messages at info level (so it's level 6).

    At first i played with syslogd by tweaking syslog.conf, which in despair led me to edit it to:
    *.* /dev/null

    Since that didn't worked i KILLed both syslogd and klogd. I still kept getting msgs to console.

    So i googled even more and found that the issue might be kernel.printk, so i changed it from "7 4 1 7" to "3 4 1 7". I also tried values "1 7 1 7".

    Nothing works!!! This is anoying as hell.

    I am running Debian unstable (i don't think that's the problem).

    TIA

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    9

    Talking

    ahhhh.... solved....
    xemacs /etc/init.d/klogd
    KLOGD="-c 1" # only msgs of higher priority (n < 1) are logged to console

    got'a love linux...

    On another problem i spent arroud two days googling in hope of solving the lack of sound with my audigy.... just to find out that the only thing i needed to do was run alsamixer and unmute the "analog/digital output"

    got'a love linux...

    i can only imagine the fun i will have setting up: mplayer (codecs probs and being able to define default streams), cd/dvd burning and the tv-card

    ohh and eventually compile the kernel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •