Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25
hi! /dev/hdc1 linux /dev/hdc2 linux swap /dev/hdc3 win95 /dev/hdc4 win95 Ext'd /dev/hdc5 FAT32 his hard disk is configured as secondary master. you must obvioulsy have two hard drives one primary ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Feb 2003
    Posts
    12

    hi!

    /dev/hdc1 linux
    /dev/hdc2 linux swap
    /dev/hdc3 win95
    /dev/hdc4 win95 Ext'd
    /dev/hdc5 FAT32
    his hard disk is configured as secondary master.

    you must obvioulsy have two hard drives one primary master and the other a slave
    he has 1 hard disk with several partitions as stated above.


    regards...

    ~noelt.

  2. #12
    Just Joined!
    Join Date
    Feb 2003
    Posts
    16
    ok now when i do that and if i get an error will i be able to boot back in windows? when is the point of no return? lol. assuming i get to where im going...then what? sorry for all the questions guys...im new to linux and i hold the world record for the number of times installing xp in one night. hehe

  3. #13
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I see no reason that you wouldn't be able to boot windows if it would fail.
    If both the Windows and Linux system are newly installed, though, it might be easier just reinstalling them both and install Linux last this time. (Try the GRUB commands first, though)
    If you didn't figure it out already, this is all because the Windows installer unconditionally overwrites the MBR with their crap MBR code.

  4. #14
    Just Joined!
    Join Date
    Feb 2003
    Posts
    12
    in case you opt to re-install it...

    1. install windows first..
    2. then install linux but put the lilo in 1st partition of linux not in MBR

    in doing so, you will not intervene with MBR(Windows loader is here by default)...

    actually since you install linux last, you can put it in MBR, windows still work and linux but once you try to re-install windows, problems comes up because the loader that linux put in MBR is no longer be found.

    that's why, it is recommended to put lilo in first partition of linux and leave the MBR - with this... if you re-install windows, linux will not be touch.

    since you install linux last, it will determine that there is another OS sitting and will configured automatically the lilo or grub for you.

    at booting linux lilo/grub will comes up first then you can choose whether you want to go to windows or linux.


    HTH...

    ~noelt.

  5. #15
    Just Joined!
    Join Date
    Feb 2003
    Posts
    16
    i had installed linux last the last time but it messed up xp saying i need to replace a"hda.dll" file and reboot once it had been done. So I replaced the needed file and it didnt work. I reformatted c: and installed xp. thats when the boot was messed. I am fairly new to linux so installing and configuring it took me hours to do. I just want linux to able to boot again without installing it. ill try what dolda is saying once i get my files backed up. Thank you for your replies. Ill be back. Hopefully with linux up. =)

  6. #16
    Just Joined!
    Join Date
    Feb 2003
    Posts
    16
    Ok i rebooted with the disk inside entered in the first line and got an error:

    Code:
    grub> root (hd2,0)
    Error 21:  Selected disk does not exist.
    i really didnt want to mess with it after this. what now?

  7. #17
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you really sure that it was hdc and not hda? Try everything with hd0 instead of hd2.

  8. #18
    Just Joined!
    Join Date
    Feb 2003
    Posts
    16
    i tried:
    Code:
    root (hd0,)
    
    Filesystem type is fat, partition type 0x83
    
    setup (hd0)
    
    ::rebooted::
    
    kernel /boot/vmlinuz-2.4.13.-24.8.0 to toot=LABEL=/
    
    Error 15: File not found.

  9. #19
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    When it enters GRUB on boot, press c to get to the command line. Then, try running these commands:
    Code:
    root (hd0,0)
    kernel /boot/vmlinuz ro root=LABEL=/
    boot
    I'm not sure if it will work , but try, and then I'll know, and I may perfect it if it doesn't work.

  10. #20
    Just Joined!
    Join Date
    Feb 2003
    Posts
    16
    Code:
    Please append correct "root=" boot option
    kernel panic:  VFS  : Unable to mount root fs on 00:00
    this is what i get.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •