Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Mpeg4ip Help Please!!!


    I'm trying to install MPEG4IP following the readme instructions but when it comes to execute "make" it gives me the following error:

    source='bitstream.cpp' object='bitstream.lo' libtool=yes \
    depfile='.deps/bitstream.Plo' tmpdepfile='.deps/bitstream.TPlo' \
    depmode=gcc3 /bin/sh ../../depcomp \
    /bin/sh ../../libtool --mode=compile c++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Werror -Wmissing-prototypes -Wmissing-declarations -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -g -O2 -DUSE_MMX -DMPEG4IP -c -o bitstream.lo `test -f bitstream.cpp || echo './'`bitstream.cpp
    mkdir .libs
    c++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Werror -Wmissing-prototypes -Wmissing-declarations -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -g -O2 -DUSE_MMX -DMPEG4IP -c bitstream.cpp -MT bitstream.lo -MD -MP -MF .deps/bitstream.TPlo -fPIC -DPIC -o .libs/bitstream.lo
    cc1plus: warnings being treated as errors
    cc1plus: warning: command line option "-Wmissing-prototypes" is valid for Ada/C/ObjC but not for C++
    cc1plus: warning: command line option "-Wmissing-declarations" is valid for C/ObjC but not for C++
    make[3]: *** [bitstream.lo] Error 1
    make[3]: Leaving directory `/home/fernando/mpeg4ip-0.9.8/lib/bitstream'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/fernando/mpeg4ip-0.9.8/lib'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/fernando/mpeg4ip-0.9.8'
    make: *** [all] Error 2

    It's quite annoying not to know the real cause. Has anybody managed to install these???

  2. #2
    Quote Originally Posted by lamadredelsapo
    I'm trying to install MPEG4IP following the readme instructions but when it comes to execute "make" it gives me the following error:

    source='bitstream.cpp' object='bitstream.lo' libtool=yes \
    depfile='.deps/bitstream.Plo' tmpdepfile='.deps/bitstream.TPlo' \
    depmode=gcc3 /bin/sh ../../depcomp \
    /bin/sh ../../libtool --mode=compile c++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Werror -Wmissing-prototypes -Wmissing-declarations -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -g -O2 -DUSE_MMX -DMPEG4IP -c -o bitstream.lo `test -f bitstream.cpp || echo './'`bitstream.cpp
    mkdir .libs
    c++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Werror -Wmissing-prototypes -Wmissing-declarations -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -g -O2 -DUSE_MMX -DMPEG4IP -c bitstream.cpp -MT bitstream.lo -MD -MP -MF .deps/bitstream.TPlo -fPIC -DPIC -o .libs/bitstream.lo
    cc1plus: warnings being treated as errors
    cc1plus: warning: command line option "-Wmissing-prototypes" is valid for Ada/C/ObjC but not for C++
    cc1plus: warning: command line option "-Wmissing-declarations" is valid for C/ObjC but not for C++
    make[3]: *** [bitstream.lo] Error 1
    make[3]: Leaving directory `/home/fernando/mpeg4ip-0.9.8/lib/bitstream'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/fernando/mpeg4ip-0.9.8/lib'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/fernando/mpeg4ip-0.9.8'
    make: *** [all] Error 2

    It's quite annoying not to know the real cause. Has anybody managed to install these???

    It looks to me that you simply need to include some flag with the make command which switches off the option to treat warnings as errors. The warnings are probably not showstoppers, but you are specifically informed that the warnings are being treated as errors, which halts the procedure.

  3. #3
    Fixing it at the moment, but thanks on the tip. It looks that is working now.

  4. $spacer_open
    $spacer_close
  5. #4

    the same problem !!

    hello,
    i have the same problem, but i don't know how to modify the make command for make it right, thank you !

  6. #5

    ./bootstrap

    Does this page help? It seems fairly informative:

    MPEG4IP - Open Streaming Video and Audio

    It says to run the ./boostrap command before running make or make install.

    Here is a link to the sourceforge forum and mailing list. Perhaps you can get help this way:

    MPEG4IP - Open Streaming Video and Audio

  7. #6
    thank you for reposting but i did it.
    this is what i whrote
    Code:
    ./bootstrap --enable-ffmpeg=/directory
    make
    i tryed many option(-k, -i,...) with the make command but nothing.
    i want just the command used by lamadredelsapo, it seems that was the right thing to do.
    thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •