Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    RPM GUI Problems with RedHat - RPM Install Dissapears!

    I'm running RH8.0 and I am a newbie - so therefore I have been messing with things here and there mostly to get my sound to work. (Which I did using the alsa driver then one day it stopped working all of a sudden which is kind of a different issue altogether) Anyways, when I run (by run I mean the old-fashioned double clicking) an rpm that isn't installed the preparing system update window comes up, completes whatever it is that it does, then dissapears. That's it! Nothing else comes up - the usual actual installer no longer comes up. What the heck is going on/what the heck did I do!??


  2. #2
    if it didnt give you any errors, i just might have installed did you try finding/running whatever was in the package

    you could always run a rpm install from a command line:
    i always use: rpm -ivh - which gives to effect something like
    blahblah 0 [##################]100
    shows progress and errors.

    what package are you tring to install program, libraries?
    if its a program you may have double check to make sure it in your path, or a library is in the library path ( i think?) now im not sure why it would be in somewhere other than the path, but never hurts to double check.

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Täby, Sweden
    RedHat's GUI wrappers for RPM installation are a bit unstable. Try upgrading them (use the command line rpm tool for that, like crippler says).

  4. $spacer_open
  5. #4
    Just double clicking on them does not install them. But alas I can - and should - use the commands which I will start using. I guess I just like it to tell me that everything installed correctly (yes I did just switch from Windows)

    Thanks guys

  6. #5
    Linux Guru
    Join Date
    Oct 2001
    Täby, Sweden
    Unix (text mode) commands usually don't give you a success message, to prevent clobbering the screen. They just give error messages when something goes wrong. And unlike Windows, the error messages actually mean something.

  7. #6

    Solution to the problem

    I found a solution I wanted to post in in case any one else has this problem. Also I must add that I didnṫ find this solution myself. This is solution is for rpm that disappear or package handler that disappears using Redhat. (Just trying to cover my keywords so others can find this)

    I had the same problem, tried the same solution with the same result - i.e. I still had the problem. Quite a few people are experiencing this. Anyway I have a fix (or hack) that seems to work for me though I can't vouch for its validity - then again when you take a look at you will see there are plenty of hacks and fixme code already so it would seem that RH can't vouch for its validity either.

    Add this line immeadiately before line 420 in (listed in your traceback):

    if h[rpm.RPMTAG_PROVIDES] is not None:

    Make sure that the indents are correct before and after this line i.e the two lines immeadiatly after should be indented to the right of this line so it should look like this:

    if h[rpm.RPMTAG_PROVIDES] is not None:
    >>>>for prov in h[rpm.RPMTAG_PROVIDES]:
    >>>>>>>>self.instProvs[prov] = pkg

    - where > is a space. The "if" line should have the same indent as the previous if statement in

    The problem is probably occuring because there are one or more entries in the rpm make up that redhat-config-packages cannot cope with. This might be because the rpm database is wrong or it might be because of a bug in redhat-config-packages - I am no expert on either. Neither am I an expert in python which is what I assume is written in. However, the fix/hack checks that the thing at index rpm.RPMTAG_PROVIDES in h has some content before trying to iterate over that content. Just to re-iterate: I don't know if this is a valid solution, use at your own risk and remember to make a copy of before you edit it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts