Find the answer to your Linux question:
Results 1 to 3 of 3
i tried to do this, but aparently i have unmet dependancies libqt3-compa-headers: depends: libqt3-headers(= 3:3.1.1- but 3:3.3.3-2 is libqt3-mt-dev epends: libqt3-headers(= 3:3.1.1- but 3:3.3.3-2 is e:unmet dependancies try using -f.... ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18

    apt-get dist-upgrade


    i tried to do this, but aparently i have unmet dependancies

    libqt3-compa-headers: depends: libqt3-headers(= 3:3.1.1- but 3:3.3.3-2 is
    libqt3-mt-devepends: libqt3-headers(= 3:3.1.1- but 3:3.3.3-2 is
    e:unmet dependancies try using -f....

    now, last time i did that apt-get -f thing, it killed like, all of my gui applications....... and apt-get also.... deleted or unsitalled them all, so im not gonna try it again:P.... i knew something was fishy when an upgrade was gonna free 300mb of space:P

    anyone know what i can do?

  2. #2
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Are you using the testing or the unstable version? These things happen time to time and it's really a b**** to resolve these. Can you post the error using the code brackets? It seems that the PHP parser has made smiley faces.
    The best things in life are free.

  3. #3
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370
    the first time i ran apt i too had many dependencies to resolve, some of them being libqt3-compa-headers and libqt3-mt-dev, but when in installed them then everything worked fine. As bpark said make sure you downloaded the correct one, maybe the file that you got is corrupt or something.
    Fixing Unix is better than working with Windows.
    http://nikhilk.homedns.org/projects/index.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •