Find the answer to your Linux question:
Results 1 to 2 of 2
I recently decided to install LFS or DIY Linux again on a box that has Slackware 11.0 on an ext3 partition, hda1. There's also an extended partition on hda2 for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602

    Can't use Parted!


    I recently decided to install LFS or DIY Linux again on a box that has Slackware 11.0 on an ext3 partition, hda1. There's also an extended partition on hda2 for my swap on hda5. So instead of redoing the partitions, and loosing all the source on the Slack partition I decided to use parted and resize it.

    I have quite a few older distros laying around (stuff I tested and didn't like) and decided to boot from one of them to resize (most are LiveCDs). SimpleMEPIS (dont' remember the version, but probably 2005 or something) boots fine, but whenever I try to use QTParted it freezes! So I decided to use parted from the command line, but when I do "check 1" it says the partition is not in a standard ext2 format (sorry, but I can't remember exactly what it says). So I tried using Gentoo 2006.0, got the same error when trying to use parted.

    So my question is, does anyone know what's wrong? Any solution? I do not want to download another distro, or version... It would be easier to blow my Slack install and download the sources again.

    EDIT: I just read on the Parted website that:
    Does GNU Parted support ext2/ext3 extended attributes?
    No, not yet
    Is this the problem?

    Thanks
    "Today you are freer than ever to do what you want, provided you can pay for it!" --Bad Religion

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Gparted doesn't support ext3 resizing. you have to convert ext3 to ext2 first. you can convert ext2 to ext3 after resizing.




    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •