I have just installed Fedora Core 1. When launching up2date, I see a lot of updates to download and install, if I start this process it stops immediately.
in the up2date panel, I see it is advisable to upgrade up2date from 4.1.16 to 4.1.21.
I downloaded the last versione but when I try to upgrade (rpm Uvh package), an error occurs (something like 4.1.16 is needed by up2date-gnome).
I checked with rpm -qa up2date* and I see I have up2date 4.1.16 and up2date-gnome 4.1.16 (this is a new installation).

How can I upgrade successfully and get the updates?

Thanks very much.