Find the answer to your Linux question:
Results 1 to 5 of 5
I'm multibooting and something has changed about disk order in GRUB, I think, help... I am multibooting with GRUB several Linux distros and Win XP. For a reason that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15

    Please help me with my multibooting catastrophe. GRUB went bad somehow.


    I'm multibooting and something has changed about disk order in GRUB, I think, help...
    I am multibooting with GRUB several Linux distros and Win XP. For a reason that I can't figure out, almost all of the distros on two of my disks (I am using three currently which are partitioned for Linux) have quit booting from GRUB.

    Following is my GRUB menu.lst from the MBR.

    *notes:
    /dev/hda or hd0 will boot
    /dev/hde or hd1 won't boot any distro other than Zenlinux (from the Scientific Linux entry?!?!?!?)
    /dev/hdg or hd2 won't boot any distro

    **** What is odd is that a few of the distros on hd1 try to boot the distros of hd2. That is why I wonder if something has changed about how GRUB sees the disk order. The disk order has not changed in the BIOS. I had a couple of difficult to multiboot distros such as aLinux and Linspire installed. I formatted those partitions (as a first step in trying to fix this) so they are no longer on the system, the menu.lst reflects that. I really don't know what screwed the system up. The only things I did after the last time that I know that it worked properly and booted every Linux are: 1. used synaptic to install a i686 kernel for PCLinuxOS (on the menu.lst), installed aLinux and MyahOS on the now vacant hdi (hd3). I removed MyahOS and aLinux form hd3 as my first step in trying to fix all of this. I am chainloading all of the distros except PCLinuxOS as you can see from the GRUB menu.lst. I will make notes to the side about what is gong on when I try to boot the distros and which bootloader the distro uses.

    timeout 10
    shade 1
    viewport 3 2 77 22
    splashimage (hd0,1)/boot/grub/mdv-grub_splash.xpm.gz
    default 0

    title PCLinuxOS LiveCD Kernel GRUB, boots
    kernel (hd0,1)/boot/vmlinuz-2.6.16.27.tex1.lve root=/dev/hda2 splash=silent vga=788
    initrd (hd0,1)/boot/initrd-2.6.16.27.tex1.lve.img

    title PCLinuxOS i686 kernel GRUB, boots
    kernel (hd0,1)/boot/vmlinuz-2.6.16.29.tex1 root=/dev/hda2 splash=silent vga=788
    initrd (hd0,1)/boot/initrd-2.6.16.29.tex1.img

    title Windows_XP boots
    root (hd0,0)
    chainloader +1

    title Suse 10.1 GRUB, boots
    root (hd0,4)
    chainloader +1

    title Ubuntu GRUB, boots
    root (hd0,5)
    chainloader +1

    title Blag GRUB, boots
    root (hd0,6)
    chainloader +1

    title Mepis GRUB, boots
    root (hd0,7)
    chainloader +1

    title elive GRUB, boots
    root (hd0,
    chainloader +1

    title Freespire GRUB, boots
    root (hd0,9)
    chainloader +1

    title Momonga GRUB, error 15
    root (hd1,4)
    chainloader +1

    title Frugalware GRUB, tries to boot VLOS on (hd2,5) but gets error 15
    root (hd1,5)
    chainloader +1

    title KateOS Lilo, tries to boot Vine on (hd2,6) but gets error 15
    root (hd1,6)
    chainloader +1

    title Scientific Linux GRUB, boots Zenwalk on (hd2,7) successfully ?!?!?!?
    root (hd1,7)
    chainloader +1

    title Sabayon GRUB, error 22
    root (hd1,10)
    chainloader +1

    title SAM cl GRUB, (I think) tries to boot Kororaa on (hd2,9)
    root (hd1,9)
    chainloader +1

    title CentOS GRUB prompt
    root (hd1,
    chainloader +1

    title Mandriva GRUB, error 15. Listed as ext2fs and I installed as ReiserFS
    root (hd2,4)
    chainloader +1

    title VLOS GRUB, error 15
    root (hd2,5)
    chainloader +1

    title Vine GRUB, error 15
    root (hd2,6)
    chainloader +1

    title Zen lilo (I think), error 13
    root (hd2,7)
    chainloader +1

    title Fox GRUB, error 13
    root (hd2,
    chainloader +1

    title Kororaa GRUB, error 13
    root (hd2,9)
    chainloader +1

  2. #2
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    OK, that will have to wait until tonight when I get home from work. Please check back.

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Location
    Augustana College
    Posts
    69
    holy crap, dude, that's called running every distro under the sun! I don't have nearly enough hard drive space :o

    Anyway, to answer your question, couldn't you boot to one of the existing distros and reinstall Grub from there? With this big a setup, you'll want to save your existing conf file to help reconstruct the new one.

    Wait, taking a closer look at your config, I take it you have individual bootloaders installed on each root partition, so there's just one grub file which chooses a partition, and then that partition loads another bootloader. That makes the lilo error make a lot more sense. Yeah, reinstall grub to the mbr, and where you're getting errors that don't have to do with grub (like in the KateOS and Zen entries), that means you need to reinstall the bootloaders that are sitting on those individual partitions. Good luck!

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    Thanks,

    Yeah, there is a bootloader in the root of each partition, almost all of them have GRUB

    All of the ones that won't boot went bad all at once. That is what I can't figure out. And I did put GRUB in each of the GRUB booted distros again, to no avail.

    I ran:
    root (hdx,y)
    setuo (hdx,y) for each of those distros and not one of them recovered due to this.

    I am wondering if I have a mis-jumpered hdi (hd2) and when I install an OS on it, the disk order between hd2 and hd1 switch for some reason and screw everything up. They may be on the same cable ? I have to check into this.
    The other possibility is that two of the distros that I installe last have cheesey bootloaders (they sure appear to...) and they screwed things up.

    B

  5. #5
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    Solved. But I don't know how. All I did was install SUSE 10.2 over the SUSE 10.1 that resided in hda5. Now everything boots up via the chainload entries posted in my original post with not one other change or troubleshooting step taken. I have no idea.... unless SUSE 10.1's bootloader caused all of the original prolblem somehow and installing 10.2 over it fixed everything. hmmmm...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •