Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, Please help me to over come these errors when i tried to install DirectFB over RedHat Linux 9.0. I enabled the FrameBuffer device and the necessary things to work ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    1

    Linux Frame Buffer & Direct FB


    Hi,

    Please help me to over come these errors when i tried to install DirectFB over RedHat Linux 9.0. I enabled the FrameBuffer device and the necessary things to work the DirectFB and recompiled the kernel. But when i tried to execute the DirectFB program it is throwing the following errors. since i am new to Linux i couldn't understand wat to do. Please help me to solve this as soon as possible.



    The Error message on the console is:

    (*) Single Application Core. (with MMX support) (2004-04-07 11:43)
    (*) DirectFB/misc/memcpy: using MMXEXT optimized memcpy()
    (*) DirectFB/InputDevice: IMPS/2 Mouse 0.9 (convergence integrated media GmbH)
    (*) DirectFB/InputDevice: Keyboard 0.9 (convergence integrated media GmbH)
    (*) MMX detected and enabled
    (*) DirectFB/GraphicsDevice: MMX Software Rasterizer 0.6 (convergence integrated
    media GmbH)
    (!) DirectFB/core/fbdev: No supported modes found in /etc/fb.modes and current
    mode
    not supported!
    (!) DirectFB/core/fbdev: Current mode's pixelformat: rgba 6/0, 6/0, 6/0, 0/0
    (4bit)
    (!) DirectFB/Core/layers: Failed to initialize layer 0!
    (!) DirectFB/Core: Could not initialize 'layers' core!
    --> General initialization failure!
    (!) DirectFB/Core: Error during initialization (General initialization failure!)
    (#) DirectFBError [DirectFBCreate() failed]: General initialization failure!

  2. #2
    Linux User
    Join Date
    Aug 2003
    Posts
    289
    a quick google search will give you a lot of answers. i encountered the same problem not too long ago. my fb.modes configuration where incorrect. i don't know though if we have the same problems. so try this:

    http://www.directfb.org/documentation/faq.xml
    Registered User #345074

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •