Find the answer to your Linux question:
Results 1 to 3 of 3
As you can see I'm trying to upgrade my XFree86 to 4.3 but whenever I issue the command to test it I cant get any feedback what so ever, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2003
    Location
    Kansas
    Posts
    9

    Upgrading XFree86-4.3


    As you can see I'm trying to upgrade my XFree86 to 4.3 but whenever I issue the command to test it I cant get any feedback what so ever, but if I just try to test one package I get feed back from the konsole. So what is the problem here.

    [root@ip68-103-129-25 xfree]# ls
    fontconfig-2.1-7mdk.i586.rpm XFree86-100dpi-fonts-4.3-1mdk.i586.rpm
    fontconfig-devel-2.1-5.i386.rpm XFree86-4.3-1mdk.i586.rpm
    glibc-2.3.1-10mdk.i586.rpm XFree86-75dpi-fonts-4.3-1mdk.i586.rpm
    glibc_lsb-2.2.90-8.1mdk.i586.rpm XFree86-devel-4.3-1mdk.i586.rpm
    ifplugd-0.13-3mdk.i586.rpm XFree86-libs-4.3-1mdk.i586.rpm
    initscripts-7.06-8mdk.i586.rpm XFree86-server-4.3-1mdk.i586.rpm
    libfontconfig1-2.1-7mdk.i586.rpm XFree86-xfs-4.3-1mdk.i586.rpm
    locales-2.3.1.4-6mdk.i586.rpm
    [root@ip68-103-129-25 xfree]# rpm -Uvh --test *.rpm
    [root@ip68-103-129-25 xfree]# rpm -ivh --test *.rpm
    [root@ip68-103-129-25 xfree]# rpm -Uvh --test fontconfig-2.1-7mdk.i586.rpm
    error: failed dependencies:
    libfontconfig1 >= 2.1-7mdk is needed by fontconfig-2.1-7mdk
    libfontconfig.so.1 is needed by fontconfig-2.1-7mdk
    [root@ip68-103-129-25 xfree]# rpm -Uvh *.rpm
    [root@ip68-103-129-25 xfree]#

    No feedback once so ever when trying to install

    Thanks for your help

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I have no idea, yet. What happens when you try to install one that doesn't fail the dependency check, eg. libfontconfig1? Do you get feedback then?

  3. #3
    Just Joined!
    Join Date
    Mar 2003
    Location
    Kansas
    Posts
    9
    They all fail depends, but I can install other rpms such as amsn messenger without any problems whatsoever. I installed kde 3.1 earlier today without any trouble and then this. I got all of these rpms from mandrake cooker.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •