Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Trying to get this working. Installed red hat 8. with apache, mysql, php as initial install options php works with a test <?php info()?> shows --with-mysql=shared/usr but I cannot access ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2003
    Location
    USA
    Posts
    18

    red hat , apache , mysql and php


    Trying to get this working.
    Installed red hat 8. with apache, mysql, php as initial install options
    php works with a test <?php info()?> shows --with-mysql=shared/usr

    but I cannot access functions of mysql I get an err
    Fatal error: Call to undefined function: mysql_connect() in /var/www/html/view.php on line 1

    any ideas

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Do you have mysql support in your PHP distribution? Is this somehing that you've compiled yourself or something that came with the distro?

  3. #3
    Just Joined!
    Join Date
    Mar 2003
    Location
    USA
    Posts
    18

    came with

    this came with the distro and I chose the options in red hat setup to run php. mysql and apache.. I didn't compile it by hand.

    edit:
    the php is 4.2.2 which should support mysql

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2003
    Location
    USA
    Posts
    18

    help

    bump

  6. #5
    Linux Newbie
    Join Date
    Aug 2001
    Location
    USA, Texas
    Posts
    217
    Have you installed php-mysql? If not ... that could be your problem.
    [ [ SykkN alloc ] initWithThePowerTo: destroyYouAll ];
    /* Don\'t make me use it! */

  7. #6
    Just Joined!
    Join Date
    Mar 2003
    Location
    USA
    Posts
    18

    install

    I installed apache,php and mysql all at initial os install
    php works (ie php info gives me details such as --with-mysql (installed))
    but database access does not.

  8. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What sykkn means is that there is a package that is required for the actual integration between PHP and MySQL, namely the php-mysql package. It mainly provides the shared object /usr/lib/php4/mysql.so.

  9. #8
    Just Joined!
    Join Date
    Mar 2003
    Location
    USA
    Posts
    18

    started over - worse off

    Installed red hat without apache , php or mysql
    then downloaded all 3
    unzipped.
    tried to install mysql got errors
    ran rpm and installed mysql
    now my sql says
    access denied for user root@localhost (using password no)

    any ideas why I cannot log into mysql

    then I plan on reinstalling php and apache
    is the php-mysql thing in the php download? or is that somewhere else

  10. #9
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Code:
    mysql_install_db
    to reset your password.

  11. #10
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    mysql was actually a bastard to set up from source. It took me like 45 minutes, and I have done it before too. I can usually install a package in like 10 minutes (I have it down to a science). Pitfalls to watch out for: Make sure you have a default /etc/my.conf (or wherever your sysconfdir is). Make sure it is actually named my.cnf. Yeah, that took me 10 minutes to find. Also, make sure /var/data (or wherever your localstatedir is) is owned by the person running mysql (usually mysql or mysqld or daemon). Make sure you have innodb either set up correctly, or turned off. That was another 15-20 minutes. Stupid mysql It is okay, the end result (bugzilla running happily) was worth it.
    I respectfully decline the invitation to join your delusion.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •