Find the answer to your Linux question:
Results 1 to 3 of 3
could someone please tell me how i can disable a partition or a hard drive so that linux doesn't try to check for errors and mount it during the boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    3

    How do I keep linux from mounting a partition/hd during boot


    could someone please tell me how i can disable a partition or a hard drive so that linux doesn't try to check for errors and mount it during the boot process? i'm using mdk10 with lilo as the bootloader.

    the reason i want to do this is:

    a) my mobo has 2 ports for SATA drives, but i only have one connected... as a result, the boot stops for about 20 seconds trying to detect the second SATA drive before saying that it is not responding and continueing...

    b) when the boot process gets to the part where it checks the partitions for errors, it fails, saying that hde7 is not a valid ext2/ext3 filesystem... ... well it just happens to be that hde7 is an NTFS partition i use for windows... so it's not really a big surprise that it's not in ext2/ext3 format... ... but this keeps me from starting linux, so it's rather annoying.

    it'd be great if someone could tell me how to make linux ignore those two things (i'm pretty sure that there are some settings i could change in lilo via command line to do this, but i don't know what settings these are...). if there's some other solution to one of the problems, that would be great too. thanks for any help

  2. #2
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    In your /etc/fstab add noauto as an option this will stop it being mounted at boot time. And i beleve you should set pass to 0 like so to stop it being checked.

    Code:
    /dev/hda1 / ext3 noauto 0 0

  3. #3
    Just Joined!
    Join Date
    May 2004
    Posts
    3
    thanks so much for the tip!! something was really weird with my config...

    i opened /etc/fstab and took a look at the settings and saw that two of the lines looked like this:

    Code:
    /dev/hde7 /home ext3 defaults 1 2
    ...
    /dev/hde6 /mnt/win_c2 ntfs umask=0, nfs=utf8,ro 0 0


    i was positive that hde7 was the windows ntfs partition... but i exited the editor and did a "fdisk -l" to make sure, and yep sure enough, i was right.
    for some reason, the config screwed up and tried to mount my ntfs partition unto my home directory as an ext3 fs!! that didn't work too well... :P

    this was a fresh install too! maybe a bug in the mandrake 10 installer? hm... anyway thanks for the tip, solved that problem by switching hde7 and hde6 in the /etc/fstab file so that they are where they belong.

    as for the other issue i had, i solved that by adding "hdg=noprobe" to the "append=..." line in /etc/lilo.conf... got that tip from another forum.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •