Find the answer to your Linux question:
Results 1 to 7 of 7
OK. Well, I finally got around to installing Linux (SuSe 8.1) again, and it is working great. It dual boots with WinXP perfectly, and I did the thing where you ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2003
    Posts
    36

    How do you give a user root access?


    OK. Well, I finally got around to installing Linux (SuSe 8.1) again, and it is working great. It dual boots with WinXP perfectly, and I did the thing where you mount the windows partition to get access to it from the linux partition. Anyways, to edit certain files and do other things, they require a higher permissions setting. I only have one account on my box, and i gave it access to everything, but it doesnt have write permissions for a lot of things. any ideas how to give my account totally access?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The entire idea with a normal user account is to not have complete access to everything. If that's what you want, you can just as well log in as root directly. There are several reasons not to do that, though, among others that normal user software usually isn't as secure as what is normally requried by root access, meaning that if someone hacks into a user utility, like gaim, over the internet when you're logged in as root, they can trash your entire system.

  3. #3
    Linux User
    Join Date
    Feb 2003
    Location
    Norway, Asker
    Posts
    267
    in /etc/passwd, set the uid and gid to 0. should look something like this:

    Code:
    user:x:0:0::/home/user:/bin/bash
    but listen to dolda, running root is not an good idea. switch from normal user to root with

    Code:
    su -
    if you need rootprivilegies some times

  4. #4
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    I would just use sudo if you need to do anything with root.

  5. #5
    Just Joined!
    Join Date
    Jan 2003
    Posts
    36
    Thanks for the help. Just another quick question. As I stated earlier, I did the thing where you can access files on the ntfs partition. Now, I want to access my mp3 collection on that partition. When using XMMS and navigating to the folder on the ntfs where the mp3s are stored, it says that it does not have permission to access those files. Any ideas how to let XMMS access the mp3s?

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Mount the NTFS partition with the mount option "umask=222".

  7. #7
    Just Joined!
    Join Date
    Jan 2003
    Posts
    36
    thanks for all the help. everything is working fine now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •