Find the answer to your Linux question:
Results 1 to 9 of 9
I dual boot windows xp sp2 and SuSE 10.2 on my laptop. It worked fine for a while booting into linux and windows. Now when I boot into XP and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Location
    Missouri
    Posts
    25

    GRUB stops working after booting to Windows XP


    I dual boot windows xp sp2 and SuSE 10.2 on my laptop. It worked fine for a while booting into linux and windows. Now when I boot into XP and shutdown or restart, GRUB doesn't load and the computer just keeps rebooting. To fix it, I have to boot to the SuSE cd and run an "upgrade" to repair the boot loader. As long as I don't boot to XP, GRUB works fine.

    Is this a bug with SuSE or what? What can I do to fix this?

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Can you post your
    Code:
    /boot/grub/menu.lst
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Location
    Missouri
    Posts
    25
    Code:
    # Modified by YaST2. Last modification on Thu Apr 19 07:45:00 CDT 2007
    default 0
    timeout 8
    gfxmenu (hd0,5)/boot/message
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 10.2
        root (hd0,5)
        kernel /boot/vmlinuz root=/dev/sda6 vga=0x314 resume=/dev/sda5 splash=silent  showopts
        initrd /boot/initrd
    
    ###Don't change this comment - YaST2 identifier: Original name: windows###
    title Windows
        rootnoverify (hd0,0)
        chainloader (hd0,0)+1
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 10.2
        root (hd0,5)
        kernel /boot/vmlinuz root=/dev/sda6 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
        initrd /boot/initrd
    
    ###Don't change this comment - YaST2 identifier: Original name: xen###
    title XEN
        root (hd0,5)
        kernel /boot/xen.gz 
        module /boot/vmlinuz-xen root=/dev/sda6 vga=0x314    resume=/dev/sda5 splash=silent showopts
        module /boot/initrd-xen

  4. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Edit that file by making the windows section into
    Code:
    title Windows XP
    rootnoverify (hd0,0)
    makeactive
    chainloader +1
    Brilliant Mediocrity - Making Failure Look Good

  5. #5
    Just Joined!
    Join Date
    Oct 2006
    Location
    Missouri
    Posts
    25
    That still didn't fix my problem. I changed menu.lst, rebooted and logged into XP. I rebooted after logging into XP and it started looping again.

    The GRUB boot screen doesn't even come up. It flashes "GRUB Loading" really fast and then reboots.

    Anybody else know how to fix this?

  6. #6
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Wait, are you actually logging into windows?
    Brilliant Mediocrity - Making Failure Look Good

  7. #7
    Just Joined!
    Join Date
    Oct 2006
    Location
    Missouri
    Posts
    25
    Yes.....once I run the repair of linux, GRUB comes back up after I reboot. BUT, as soon as I log into Windows XP, GRUB gets messed up and it won't load up enough to show the operating systems. If I just keep logging in to linux after doing the upgrade, GRUB doesn't get messed up.

  8. #8
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Ok, here is the solution. Windows dynamic disk partitioning scheme is messing up grub everytime you load windows. So we are going make grub skip the files that windows deletes.
    In suse you need to remove the stage1_5 files
    Code:
    mv /boot/grub/*stage1_5 /root
    Now rerun the grub install compand
    Code:
    grub-install /dev/hda
    It will give some error, but it is fine. Now reboot into windows reboot again and try Suse
    http://www.nabble.com/Windows-zappin...-t2013401.html
    http://savannah.gnu.org/bugs/?15048
    Brilliant Mediocrity - Making Failure Look Good

  9. #9
    Just Joined!
    Join Date
    Oct 2006
    Location
    Missouri
    Posts
    25
    I was looking at the second link that you posted and I found out the solution. We use Zenworks 7 for desktop and computer management and I remember I started having the problem after installing Zenworks Desktop Management on my system.

    Code:
    If your system is using Novell ZenWorks, then remove this registry key: 
    
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] 
    
    
    "System"="ziswin.exe" 
    
    
    You'll need to reinstall GRUB again after doing this, but thereafter you should be fine. This setting causes some information to be written into the MBR each time you boot and thus hoses up GRUB.
    This took care of me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •