Find the answer to your Linux question:
Results 1 to 3 of 3
Have been trying to install Debian to my pc by hoor or by crook. Debian Woody installs fine but doesn't have an option for lilo to floppy. Debian Sarge installs ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305

    Debian and NIC


    Have been trying to install Debian to my pc by hoor or by crook.
    Debian Woody installs fine but doesn't have an option for lilo to floppy.

    Debian Sarge installs fine(ish) but refuses to allow eth0 to operate.

    Knoppix works fine but the hd install messes up eth0.

    Morphix works fine but after hd install, guess what? Yup, no eth0 working.

    Done all sorts of tweaking to get the bugger to work but to no avail, NIC module loaded, lspci list it, lsmod? shows it there but ifup eth0 gives eth0 unknown. Pah.

    And the worst thing of all is that whenever I've been fiddling with installing Debian than the eth0 won't load under Mandrake until it's had at least one shutdown and reboot, a single reboot and no eth0 in Mandrake!!

    Aaaaaagggghhhhhhh!!!!!
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    Mars
    Posts
    62
    try using ifconfig to see if it lits any other eth except the loopback if it doest, then modprobe module name, if that doesn't work you might have to put it in the /etc/(modules file i don't remember the debian ones name), that doesn't work throw in a compiled kernel that you did yourself thats if you can get the source otherwise download it in your other distro and build it there. Debian has successfully never worked with my ethernet card eventhough its supported by their stable woody he he dunnno why its kernel hates me oh well he eh. Best of luck

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    "ifconfig to see if it lits any other eth except the loopback" - been there.

    "modprobe module name" - done that.

    "if that doesn't work you might have to put it in the /etc/(modules" - bunged it in.

    Still don't work. Guess it's a supernatural thing.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •