Find the answer to your Linux question:
Results 1 to 7 of 7
Hey, I have a headless server (it does have a monitor and keyboard for maintainence purposes) running Ubuntu 6.06 server set up as a LAMP server. I usually log into ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    SSH connection refused


    Hey, I have a headless server (it does have a monitor and keyboard for maintainence purposes) running Ubuntu 6.06 server set up as a LAMP server. I usually log into it on my windows laptop through Putty, but earlier today the power went out and it turned out it was plugged into the wrong damn plug on my UPS. Now that the power's back on and it's up and running, whenever I try to log in through Putty I get a "connection refused" error. I have port forewarding on it for port 22 on my router, not that that should matter since I'm just trying to get it on my local network. The Apache server is running fine and I have no problem accessing that from the laptop, but I still can't log in through SSH. Any ideas?

  2. #2
    Just Joined!
    Join Date
    Aug 2007
    Posts
    33
    try to do a port scan with nmap to check what ports are open. try telnet etc. if u have an access to it. another possiblity might be that after the machine got restarted the ssh deamon would not have started or may have some errors b'cas of which the problem is arising.

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    5
    did you look in log files, they may be handy to get some information.
    /var/log/..
    Can you find something?

  4. #4
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3
    I got frustrated to the point that I reinstalled the system (I keep the data in a different partition for this reason), and now that it has a new system, I still have the same problem. I made sure to install the openssh server and rebooted just to be safe. Now I can still access Apache through the web browser on my laptop, but still no ssh. nmap shows port 22 as open and sshd is running, but still no luck.

  5. #5
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Have a look at /var/log/messages for anything related to sshd. Might be a clue in there.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  6. #6
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    Eureka!

    I didn't think to check the log files before re-installing the system, and I didn't think they would show me much after re-installing.

    But here's the problem, when the power went out, the computer and the router were plugged into the non-battery plugs on the UPS. I switched them to the battery powered ones and they came on. Here's the thing, the router came online before the server was finished booting up, so the laptop connected to it first since the laptop never shut off thanks to it's internal battery. After all that frustration and work, it turned out that the whole problem was that the server was on a different local IP, duh!

    I'm not as angry since I put the system in it's own partition so there's no data loss, just a bunch of time that could've easily been spent by quickly logging into my router and finding out the new local IP for the server, as well as buying beer.

  7. #7
    Just Joined!
    Join Date
    Aug 2007
    Location
    Midlands, UK
    Posts
    14
    The other thing to note is that when the machine, your server, powers back up after the power loss it checks itself to make sure it's ok.

    I've got a similar setup here, and despite power problems it's survived ok.

    I suppose it's a lesson Next time if you logged into your router you could see "attached devices" from there...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •