Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, I am a newbie here. I got a problem connecting to the Internet. I have already set up the internet connection using the Kppp as well as the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Location
    Singapore
    Posts
    2

    Kppp daemon died unexpectedly


    Hi all,
    I am a newbie here. I got a problem connecting to the Internet. I have already set up the internet connection using the Kppp as well as the the one in system (control panel). Here's what I did:

    First, I deleted the existing connection in the control panel and created the new one. After creating the connection in the control panel, I created a new account in the Kppp. I used PAP as the connection type.
    One thing that I read from the Mandrake 10 documentation was about the lock file. It said that lock file shouldn't be used as it would cause "Kppp daemon died unexpectedly". I unchecked the lock file box in the Kppp, but the message still appeared. Actually the modem was able to dial to the ISP correctly. But when it came to the authentication, the message always appeared.

    What could be the cause of this problem? I have tried setting up this internet connection for 2 weeks and still can't find a way to solve this problem. Hope you can help me in this problem. Thank you in advance for any suggestion you may have.

    Best regards,
    Christian

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2
    I had the same problem quite recently and I overcame it by decreasing the connection speed to 115200 and using PAP only authentication method.

    Why don't you give it a try.

    peace.

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Location
    Singapore
    Posts
    2

    Still doesn't work... :-(

    Hi Angel,
    Thanks for your reply regarding the internet connection. Actually my last configuration for the connection speed was already 115200. So, I tried reducing it to 57600. But it still doesn't work. The message still appeared, with the exit status:16. By the way, when I checked the login script debug window, here's what was stated there:

    ATZ
    OK
    ATM1L3
    OK
    ATDT(my ISP phone number)
    Connect 115200

    It stopped there before the error message appeared. Furthermore, I tried checking the ppp log, and here's what was stated:

    pppd 2.4.1 started by root, uid 0
    using channel 4
    using interface ppp0
    connect ppp0 <--> /dev/tts/1
    sent...
    .
    .
    .
    rcvd...
    hangup (SIGHUP)
    modem hangup
    connection terminated
    exit

    In the section between sent... and rcvd..., there were some more sent and rcvd commands with different parameters (which I don't understand what those parameters meant).

    By the way, some configurations in my connection are as follows:
    Flow control : hardware (CRTSCTS)
    Line termination: CR/LF
    pppd timeout: 60 sec

    I also used dynamic IP address and automatic DNS.

    Well, that's all about my current status and configuration. I still don't know what else I need to configure to make it work...

    Thanks and regards,

    Christian

  4. #4
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2
    Everything looks ok to me except that "/dev/tts/1" statement on the log's message. If you have an external modem may be you can try that on port ttyS0 (com1). Change the device to /dev/ttyS0 (ttyS0 if on com2). Also try changing the flow control to 'none' or 'software'. (personally 'none' has worked just fine for me).


    peace,
    angel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •