Find the answer to your Linux question:
Results 1 to 9 of 9
Hi all, I'm a novice to Linux/Unix. Now of the softwares that I need to work on, is a client-server software. The Server installed on RHEL AS 4.5 and the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    11

    cannot ping RHEL AS 4.5 box from a Windows XP Pro box


    Hi all,

    I'm a novice to Linux/Unix. Now of the softwares that I need to work on, is a client-server software. The Server installed on RHEL AS 4.5 and the client on Windows XP Pro. I have successfully installed the Server on the RHEL AS 4.5 box.

    Now, I'm trying to ping the RHEL AS 4.5 box from Windows XP Pro and the request times out. This is what I get:

    Code:
    C:\Documents and Settings\Administrator>ping 198.168.1.104
    
    Pinging 198.168.1.104 with 32 bytes of data:
    
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    
    Ping statistics for 198.168.1.104:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    But I'm able to connect to RHEL AS 4.5 box through putty using SSH.

    My ifconfig, network and hosts files on the RHEL box are as below:

    Code:
    [root@localhost ~]# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:15:58:81:BC:FF
              inet addr:192.168.1.104  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::215:58ff:fe81:bcff/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2067 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1322 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:100
              RX bytes:243338 (237.6 KiB)  TX bytes:203896 (199.1 KiB)
              Base address:0x3000 Memory:ee000000-ee020000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:246370 errors:0 dropped:0 overruns:0 frame:0
              TX packets:246370 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:129362278 (123.3 MiB)  TX bytes:129362278 (123.3 MiB)
    
    [root@localhost ~]#
    Code:
    [root@localhost ~]# cat /etc/sysconfig/network
    NETWORKING=yes
    HOSTNAME=localhost.localdomain
    [root@localhost ~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost       my
    [root@localhost ~]#
    I need to access the RHEL box through the Internet explorer web browser on the Windows XP Pro box inorder to configure certain things of the software that I installed on the RHEL box. I need to access it by entering the following URL:
    Code:
    http://192.168.1.104:9080.192.168.1.104
    where 9080 is the port number. When I do the same URL now, it returns nothing. And I suspect this is due to the Windows XP Pro box not able to ping the RHEL box.

    How can I set it up so that I'm able to ping the RHEL box from the Windows XP Pro box successfully.

    Your help is tremendously appreciated.

    rhelasuser.

  2. #2
    Just Joined!
    Join Date
    May 2007
    Location
    Southwest Missouri
    Posts
    24
    Quote Originally Posted by rhelasuser View Post
    Hi all,

    Code:
    C:\Documents and Settings\Administrator>ping 198.168.1.104
    But I'm able to connect to RHEL AS 4.5 box through putty using SSH.

    My ifconfig, network and hosts files on the RHEL box are as below:

    Code:
    [root@localhost ~]# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:15:58:81:BC:FF
              inet addr:192.168.1.105  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::215:58ff:fe81:bcff/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2067 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1322 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:100
              RX bytes:243338 (237.6 KiB)  TX bytes:203896 (199.1 KiB)
              Base address:0x3000 Memory:ee000000-ee020000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:246370 errors:0 dropped:0 overruns:0 frame:0
              TX packets:246370 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:129362278 (123.3 MiB)  TX bytes:129362278 (123.3 MiB)
    
    [root@localhost ~]#
    rhelasuser.
    You are using the wrong IP Address. You try to ping 192.168.1.104, but the server's address is 192.168.1.105.

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    11
    Hi wsurritte,

    I'm extremely sorry. That was a typo. I have edited/corrected my post to reflect the same. 192.168.1.104 is the IP address.

    Many thanks,
    rhelasuser.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Quote Originally Posted by rhelasuser
    I need to access the RHEL box through the Internet explorer web browser on the Windows XP Pro box inorder to configure certain things of the software that I installed on the RHEL box. I need to access it by entering the following URL:
    Code:
    http://192.168.1.104:9080.192.168.1.104
    where 9080 is the port number. When I do the same URL now, it returns nothing.
    That IP/port specification is a tad strange. Try: http://192.168.1.104:9080

    If that doesn't work, log on to the RH server and post the results of:
    # netstat -ltn

    and

    # iptables -nvL

    (put the results in CODE tags so that they are decipherable)

    Quote Originally Posted by rhelasuser
    And I suspect this is due to the Windows XP Pro box not able to ping the RHEL box.
    No. The ping failures are probably because icmp traffic is being rejected by a host-level firewall or some other hop along the way.

    Quote Originally Posted by rhelasuser
    How can I set it up so that I'm able to ping the RHEL box from the Windows XP Pro box successfully.
    Do you need to be able to successfully ping to the RH box or do you need to be able to access the application that is listening on tcp port 9080? Those are two different issues.

  6. #5
    Just Joined!
    Join Date
    Aug 2007
    Posts
    11

    Thumbs up

    Thanks a gazillion times. You are absolutely right. Didn't realize that they were different issues. I cannot believe I didn't try just using:

    Code:
    http://192.168.1.104:9080
    And it works. Thanks again!!

    But I would really like to know why I'm not able to ping the RHEL box through Win XP Pro. Pardon my lack of knowledge.

    The output of "netstat -ltn" is:

    Code:
    [root@localhost ~]# netstat -ltn
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State
    tcp        0      0 0.0.0.0:139                 0.0.0.0:*                   LISTEN
    tcp        0      0 0.0.0.0:523                 0.0.0.0:*                   LISTEN
    tcp        0      0 0.0.0.0:5900                0.0.0.0:*                   LISTEN
    tcp        0      0 0.0.0.0:876                 0.0.0.0:*                   LISTEN
    tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN
    tcp        0      0 0.0.0.0:31538               0.0.0.0:*                   LISTEN
    tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN
    tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN
    tcp        0      0 0.0.0.0:445                 0.0.0.0:*                   LISTEN
    tcp        0      0 :::9443                     :::*                        LISTEN
    tcp        0      0 :::9060                     :::*                        LISTEN
    tcp        0      0 :::32778                    :::*                        LISTEN
    tcp        0      0 :::7276                     :::*                        LISTEN
    tcp        0      0 :::9100                     :::*                        LISTEN
    tcp        0      0 :::31533                    :::*                        LISTEN
    tcp        0      0 :::8880                     :::*                        LISTEN
    tcp        0      0 :::9043                     :::*                        LISTEN
    tcp        0      0 :::32884                    :::*                        LISTEN
    tcp        0      0 :::32885                    :::*                        LISTEN
    tcp        0      0 :::7286                     :::*                        LISTEN
    tcp        0      0 :::22                       :::*                        LISTEN
    tcp        0      0 :::32888                    :::*                        LISTEN
    tcp        0      0 :::9080                     :::*                        LISTEN
    tcp        0      0 :::13400                    :::*                        LISTEN
    tcp        0      0 :::32889                    :::*                        LISTEN
    tcp        0      0 :::2809                     :::*                        LISTEN
    tcp        0      0 :::9401                     :::*                        LISTEN
    tcp        0      0 :::13401                    :::*                        LISTEN
    tcp        0      0 :::9402                     :::*                        LISTEN
    tcp        0      0 :::9403                     :::*                        LISTEN
    [root@localhost ~]#
    and "iptables -nvL" is:

    Code:
    [root@localhost ~]#  iptables -nvL
    Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
     pkts bytes target     prot opt in     out     source               destination
    
    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
     pkts bytes target     prot opt in     out     source               destination
    
    Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
     pkts bytes target     prot opt in     out     source               destination
    [root@localhost ~]#
    Although, pinging the RHEL box from the Windows machine is not imperative right now, it would be nice to know why it failed? May be, I lack the basic networking knowledge. Again, thanks a lot for your help. Really appreciate it. You rock!!!

    rhelasuser.

  7. #6
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Quote Originally Posted by rhelasuser
    Although, pinging the RHEL box from the Windows machine is not imperative right now, it would be nice to know why it failed?
    Your host-level firewall on the RH box is wide open, so that does not appear to be causing it.

    You could post the results of the following command:
    # sysctl net.ipv4.icmp_echo_ignore_all

    That will tell us if you have a sysctl variable set to ignore ping requests.

    Failing that, it could be a host-level firewall issue on Windows. Or it could be your network guys have a switch or router in place that is filtering icmp traffic.

  8. #7
    Just Joined!
    Join Date
    Aug 2007
    Posts
    11
    anomie,

    You are right. I had disabled the firewall because the client-Server software that I installed was recommending it.

    Also, these two machines are at my home, the RHEL AS 4.5 box is connected by a RJ-45 cable to the Wireless router with four ports and the Windows XP box is connected to the wireless router by the Wireless card.

    I'm posting the output of the command you requested as below:

    Code:
    Last login: Sun Aug 26 21:42:13 2007 from 192.168.1.103
    [root@localhost ~]# clear
    [root@localhost ~]# sysctl net.ipv4.icmp_echo_ignore_all
    net.ipv4.icmp_echo_ignore_all = 0
    [root@localhost ~]#
    I have enabled the firewall now. There is also a tab called "SELinux", which is disabled. Do I have to worry about that?

    Please let me know if yo need any other information from my side.

    Again, your inputs are greatly appreciated. Thanks a bunch!

    rhelasuser.

  9. #8
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Ok, there is nothing on the RH box that makes me think that is where the problem is. You could confirm this by running tcpdump and watching for icmp traffic, but that is not super simple to interpret (i.e. will require a little research and reading).

    Probably your Windows box firewall or your router is blocking the icmp traffic. Shut off your Windows firewall and try again. If that doesn't work, check your network/advanced/whatever settings on the router and look for anything that filters icmp echo (ping) traffic on the network.

    SELinux is another long, complex topic.

  10. #9
    Just Joined!
    Join Date
    Aug 2007
    Posts
    11
    Hi anomie,

    Sorry for the delayed reply as I was out of town on other work. Yes. I disabled my windows firewall and it worked. I was able to ping the Linux box.

    Thanks a bunch for all your help.
    Have a fantastic long weekend,

    rhelasuser.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •