I am new to linux. I am trying to setup my system to allow other computers on my home LAN to access the internet through the linux box. I have 2 network cards in the linux host. The first card is connected to my cable modem and is device eth0. The second card is connected to a Linksys hub and is device eth1. I can currently access the internet with my browser from the linux box.
I have tried using SuSEfirewall2 to turn on masquerading for the other computers on my LAN and many other things to get this to work without success. By the way:

eth0 Link encap:Ethernet HWaddr 00:20:78:11:56:08
inet addr:24.98.119.174 Bcast:255.255.255.255 Mask:255.255.252.0
inet6 addr: fe80::220:78ff:fe11:5608/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:59936 errors:0 dropped:0 overruns:0 frame:0
TX packets:3240 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:6159792 (5.8 Mb) TX bytes:381674 (372.7 Kb)
Interrupt:10 Base address:0xc800

eth1 Link encap:Ethernet HWaddr 00:0C:76:13:36:B1
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20c:76ff:fe13:36b1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:3488 (3.4 Kb)
Interrupt:11

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:154 errors:0 dropped:0 overruns:0 frame:0
TX packets:154 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:13432 (13.1 Kb) TX bytes:13432 (13.1 Kb)

and here is my route output:

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
24.98.116.0 0.0.0.0 255.255.252.0 U 0 0 0 eth0
0.0.0.0 24.98.116.1 0.0.0.0 UG 0 0 0 eth0

I can ping 192.168.0.1 OK and the local loopback 127.0.0.1.
I cannot ping any of the local area computers that are on
192.168.0 network, I always receive a message saying that
the destination host is unreachable. Also in dmesg I receive
'eth1: no IPv6 routers present' . I can ping external domains with
and connect to the internet. I know my hardware is good since
I have no problem with the same hw in Windows XP using
ICS. I need someone to hold my hand. If anyone knows how to
setup a dual homed host which does internet sharing with a
cable modem in SuSE 8.2 please respond.

Thanks.