Find the answer to your Linux question:
Results 1 to 3 of 3
So I've been fighting this with a few days and can't seem to figure out what is going on. I have a linux box here that I've put Fedora 6/7 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    2

    Problems getting out of local network


    So I've been fighting this with a few days and can't seem to figure out what is going on. I have a linux box here that I've put Fedora 6/7 (and now DSL 3.4 as well) on and can't seem to get it to ping outside of our network. With 7 I had issues with DHCP but I switched and put 6 on and that solved that problem (switching over to static addressing also solved that) so now I have connectivity within our network (can ping our DNS server as well as resolve outside addresses such as Google). Right now DHCP and a static IP both work for a connection within the network.

    So I know that the configuration is fine (double checked the ifcfg-eth0 file as well as resolv.conf and they are set to the right IPs as well as pointing to the correct gateway) and everything seems to work fine locally. If I try to ping Google or any other public address that is pingable it will resolve the IP address but will not get any replies. Also internet traffic does not work (works internally, can access our internal web servers). So I'm trying to determine what is the cause. From all of our Windows boxes the network works fine and we can browse the Internet.

    I checked the route statements in Fedora and it has a default gateway of 10.10.10.3 (that's our router) and the proper route statements (a route for our subnet as well as a default gateway to our router).

    The only thing I can think of is configuration with our router (Cisco 1811) that I've looked through and can't seem to find anything that may be causing this.

    Any help or even ideas would be greatly appreciated. I'll post a copy of the config files (ifcfg-eth0, resolv.conf, route output).

  2. #2
    Just Joined! forgottentq's Avatar
    Join Date
    Jun 2006
    Location
    Virginia at the moment.
    Posts
    46
    does a cisco 1811 support Access Lists? If so maybe it was preconfigured to only allow certain ip's out over the network... how do the windows machines obtain their IP's? DHCP? If so from where? A simple "show run" command on the cisco will tell you if you have ACL's applied. Look at each interface and if there is an ACL it will look like this: (mine):

    interface Ethernet0
    description Internal Trusted Network
    ip address 205.97.97.254 255.255.255.0
    ip access-group 110 in
    media-type auto-select
    full-duplex
    no cdp enable

    interface Ethernet1
    description to ADNS UNCLASSIFIED TACLANE (RED)
    ip address *.*.*.* 255.255.0.0
    ip access-group 190 in
    ip ospf authentication-key 7 ****************
    ip ospf network point-to-multipoint non-broadcast
    media-type AUI
    no cdp enable

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    2
    The thing is the ACLs are set to let all traffic from the 10.10.10.x network through and it's working fine on the Windows boxes within the same subnet.

    I've tried making more ACL statements to not filter traffic at all from the specific host (right now www, dns, icmp, ftp, and a few others are allowed from hosts).

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •