Find the answer to your Linux question:
Results 1 to 10 of 10
Hey Everyone, A little while ago I decided it would be a great idea to install Mandrake Linux 10.0 on my laptop and use it for mobile computing. The results ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    1

    Excessively slow network transfer speeds from XP to Linux…


    Hey Everyone,

    A little while ago I decided it would be a great idea to install Mandrake Linux 10.0 on my laptop and use it for mobile computing. The results have been outstanding and thus far I have been extremely pleased with Linux as an OS. I am not a very big Linux Buff (read: I am highly Linux Inept) and have since run into a problem that I just haven’t been able to work out…

    A little while ago I was at a friend’s house on his network. I was using Samba to browse through his shares, grab files, etc. The browsing was easy, and the transfers where fast. Later (on or about a week from then) I went to another friends house and noticed that while I was still able to browse his shares (both friends where running Windows XP Prof.) my speed at transferring was horrid (to the tune of less than a MB a second and stalling often). Furthermore, while the transfer was in progress, my ‘connection light’ on the router would just shut off randomly (which, obviously, isn’t something it usually does).

    At the time I saw it as a bit of a fluke. It had run perfectly one time and I wrote off the poor transfer speeds and horrible connection problems to my latter friend’s aging network and PC. However, after getting home, I tried transferring some files from my Windows XP desktop to my Linux laptop. Unfortunately, the problem persisted. Not only that, but it has persisted on a variety of networks.

    I am, well, not very knowledgeable in this field and would greatly appreciate any help that some of you would be willing to offer! I would hate to think that my built in Ethernet device somehow got damaged and would hope that this problem can be fixed on the OS or software side of things. Thank you in advance for your time and recommendations on how to alleviate this dilemma!

    -K

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That sounds extremely weird. The next time this occurs (or if you can trigger it manually), try running "dmesg | tail -30" after a while and see if the kernel has spit out any errors messages about it.

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    I have had the very same problem with both RH9 and Suse 9.0 connecting to XP via samba. Never did find a solution.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  4. #4
    Just Joined!
    Join Date
    Jun 2004
    Location
    Leiria - Portugal
    Posts
    72

    Can it be because of WINS?

    I there,

    It really sounds lots of strange.

    But I'm thinking if it can't be because the WINS master browser war betwen samba and windows xp!? Can it?

    See log messages to figure out...

    Can it be because of your hardware? it can be stressed and get hot very quickly.

    With a pcmcia lan card try to run same tests at same places...

    I had to change some registry strings at my xp and win2k lan workstations to stop a lot of fights between samba and those.

    Just a guess... good luck!

    (My english is just like that error, a very strange thing )

  5. #5
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    If you put the OS level of samba to 70 or 80 it will win the WINS browser and XP will follow samba.
    Or put samba at os level 20; that way your windows WINS server will be browse master.
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  6. #6
    Just Joined!
    Join Date
    Jun 2004
    Location
    Leiria - Portugal
    Posts
    72

    Thats real true but...

    Hi there,

    It's real true that if the OS LEVEL = 70 (or grater) string came within the smb.conf file, samba will be master browser over the windows network workstations.

    But I've experimented lots of problems with that until I turn off some strings in the windows registry of my xp/2k workstations.

    Take a look at samba as wins server too. Wins service will be yet important for windows machines to work well. (as far as I know)

    I'm working with Samba of Mandrake 9,2, 10, Fedora Core 1 and 2.

    Just google a whike and it apeers lot of info about thtat registry modifications. Write now I can't post them...

    Regards to all.

  7. #7
    Just Joined!
    Join Date
    Sep 2004
    Posts
    5
    Having exactly the same problem with Samba.

    I've noticed that when you are simply copying file to or from the samba server it runs as fast as i'd expect it to. But if you open something as simple as a word document from the samba share it takes around 25 secs before it opens the file. The same pause happens when you save the word file once you have made changes. Even trying something as basic as a text file. You double click to open it, and it pauses for 25 secs then shows the contents of the file. Same yet again when saving it.

    I've tried googling but not been having much luck

    Tried setting the "os level" as low as 10, but still doesn't make any difference. Also put in a Wins server address which is used on my windows domain.

    Anyone got any other ideas?

  8. #8
    Just Joined!
    Join Date
    Jun 2005
    Posts
    1
    I am new to Linux... I have SUSE9.2 installed...

    My problem is that I can't seem to transfer large files from my Linux box to my windows box... I can transfer smaller .PDF, etc easily... But when I try to move a 2GB file, it will start, go for about 13-30 MB or so then the "time remaining" will just shoot up and it will stall... What can I do?

  9. #9
    unknown
    Guest

    Know what you mean...

    You should try to do some additional troubleshooting. I have the same issue and tried to use SFTP and SCP to see how they perform. Both appear to have the exact same issue; fast transfer from Linux to XP but as soon as you try to upload to the Linux server everything goes south. To be honest I would post how to fix this but I am still having some issues so I can’t even say this is a 100% solution. However here is what I have gleaned off Google.

    *********** General Warning ***********
    I don’t know anything about Linux. I just got my first Linux box a month ago and am slowly learning this stuff. If you notice anything a tad off then try not to flip.
    ******* You Have Been Warned**********

    This appears to be an incompatibility issue with winsock2 TCP/IP and Unix's TCP/IP. In a nutshell Winsock drops an ocational packet and Linux keeps resending data. This causes small delays of 15 ms. However when sending larger files it will get worse exponentially until you end up with 1+ secs of delay between data packets.

    The trick is to make sure your Samba server is using the *EXACT* MSS (Max Segment Size) as the XP computer. If you are off by just a bit you will have the spiraling performance issues.

    I found most of this stuff at:

    http://www.dd.iij4u.or.jp/~okuyamak/...g.english.html

    Be warned that this is a “.jp” site and the guy’s English isn’t the greatest. He has all his ducks in a row but being able to understand him is kinda tricky.

    If you Google search for “socket options”, “TCP_NODELAY SO_SNDBUF” and “TCP_NODELAY SO_RCVBUF” you should get some decent information on how to fix this.

  10. #10
    unknown
    Guest

    Phew... I'm working

    OK... So it was a packet problem.

    I ran ethereal on my XP computer and found that there were a TON of retransmit requests coming from my XP Computer. I am confused as to why because if I am sending information to the Linux box why would the XP computer need to request a duplicate packet? I decided to see what would happen if i went to 10base Half Duplex. When I did this everything worked great. My XP could also do full duplex without any trouble but would not run 100base.

    As mentioned in the Jap website this is typically a bad driver issue so i tried to update my driver. This didn't help. I started reading more about people with the same issue and found that MANY of them had Realtek Ethernet cards. It just so happens that my XP MB has an internal NIC on it that is a "Realtek 8139". I went to my local Wal-Mart and got a Linksys NC100 and disables my other NIC. After doing so my performance immediately was boosted.

    I don't think my NIC was bad per say because I was running with a XP server that was able to run fine. However I do feel the NIC on my computer was not handling the packets correctly. I am sure if I could find the appropriate driver I would be just fine but.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •