Find the answer to your Linux question:
Results 1 to 4 of 4
Ok, will I have set up RSA ssh authentication before with little trouble before on debian and ubuntu distributions. ssh-keygen -t rsa then copy the "id_rsa.pub" into the "authorized_keys" file ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    49

    Public Key/Private Key RSA SSH Authentication, incompatible versions?


    Ok, will I have set up RSA ssh authentication before with little trouble before on debian and ubuntu distributions.

    ssh-keygen -t rsa
    then copy the "id_rsa.pub" into the "authorized_keys" file of the machine you want to connect. The id_rsa.pub looks something like this
    Code:
    ssh-rsa AAAA......ADADJA== root@blimpserver

    I am doing an embedded linux project for class, running kernel 2.4.19 on a Stargate PlatformX development board. There doesnt seem to be the same options for ssh-keygen on the development board, like no -t option, but it does an rsa key by default.

    Usage: ssh-keygen [-lpqxXydc] [-b bits] [-f file] [-C comment] [-N new-pass] [-P pass]

    The identity.pub file also looks to be in a different format than the one my ubuntu server generates.

    Code:
    1024 35 14086313064907804810825517866521754118140837784925939335542483411268937340836832370814748189386402763341891581043404901505678017426480983873972803085003900580822978532819897813923466834625755697493269579774465868721063813867611736786497600964906470036339471711155154505697952148024216972525547845887976856509 root@stargate
    Its all numbers there is a 1024 and 35 in front. I am assumming the ubuntu ssh-keygen using base 64 to display number while the stargate is in decimal. Will anyway, I cannot not get passwordless ssh to work, I have mangled the /etc/ssh/ssh_config and sshd_config options endlessly and I am still unable to get it to work. I have tried adding the stargate's "identity.pub" to a "authorized_keys2" file on the ubuntu server but that still doesnt work. Posted below are the config files that I have edited in trying to get this to work.

    "ssh_config"
    Code:
    # This is ssh client systemwide configuration file.  This file provides
    # defaults for users, and the values can be changed in per-user configuration
    # files or on the command line.
    
    # Configuration data is parsed as follows:
    #  1. command line options
    #  2. user-specific file
    #  3. system-wide file
    # Any configuration value is only changed the first time it is set.
    # Thus, host-specific definitions should be at the beginning of the
    # configuration file, and defaults at the end.
    
    #######
    ### ForwardX11 & ForwardAgent
    ###   For security reasons, OpenSSH defaults to ``no'' for these settings
    ###   You should only enable them for hosts where you specifically trust the
    ###   administrators of the remote machine, otherwise you are leaving
    ###   yourself open to X11 based attacks, or to allowing your keys to be used
    ###   by others from the remote machine.   See also: ssh -X -x -A & -a options
    
    # we might as well switch them back on for localhost though
    Host localhost
        ForwardAgent yes
        ForwardX11 yes
    
    # Site-wide defaults for various options
    
    # Host *
    #   ForwardAgent no
    #   ForwardX11 no
    #   RhostsAuthentication yes
    #   RhostsRSAAuthentication yes
       RSAAuthentication yes
       PasswordAuthentication no
    #   FallBackToRsh no
    #   UseRsh no
       BatchMode yes
       CheckHostIP no
       StrictHostKeyChecking no
       IdentityFile ~/.ssh/identity
    #   Port 22
       Protocol 2,1
       Cipher blowfish
    #   EscapeChar ~
    "sshd_config"
    Code:
    # This is ssh server systemwide configuration file.
    
    Port 22 
    Protocol 2
    ListenAddress 0.0.0.0
    #ListenAddress ::
    HostKey /etc/ssh/ssh_host_key
    ServerKeyBits 1024
    LoginGraceTime 600
    KeyRegenerationInterval 3600
    PermitRootLogin yes
    #
    # Don't read ~/.rhosts and ~/.shosts files
    IgnoreRhosts yes 
    # Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
    #IgnoreUserKnownHosts yes
    StrictModes no
    X11Forwarding yes
    X11DisplayOffset 10
    #PrintMotd no
    #PrintLastLog no
    KeepAlive yes
        
    # Logging
    SyslogFacility AUTH
    LogLevel INFO
    #obsoletes QuietMode and FascistLogging
    
    RhostsAuthentication yes
    #   
    # For this to work you will also need host keys in /etc/ssh_known_hosts
    RhostsRSAAuthentication yes 
    #  
    RSAAuthentication yes
    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication yes
    PermitEmptyPasswords no
    # Uncomment to disable s/key passwords
    #SkeyAuthentication no
       
    # To change Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #AFSTokenPassing no 
    #KerberosTicketCleanup no
    
    # Kerberos TGT Passing does only work with the AFS kaserver
    #KerberosTgtPassing yes
    
    CheckMail no
    #UseLogin no
    
    #Subsystem      sftp    /usr/local/sbin/sftpd
    #MaxStartups 10:30:60
    Does anybody have an idea how I can get this working. I do have ssh-agent installed so I could use that, if it is not possible to get rsa pub/priv working. Any help would be greatly appreciated.

    thanks,
    Zack

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    49
    Bump anyone? Would this post be better suited in a different section on these forums?

  3. #3
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    IMO, you posted this appropriately.

    "kernel 2.4.19 on a Stargate PlatformX" ??

    Your problem is totally obscure, which likely explains the lack of responses. What distro is it running? Is this something you built/compiled yourself?

  4. #4
    Just Joined!
    Join Date
    Aug 2006
    Posts
    49

    Stargate PlatformX

    Quote Originally Posted by anomie View Post
    IMO, you posted this appropriately.

    "kernel 2.4.19 on a Stargate PlatformX" ??

    Your problem is totally obscure, which likely explains the lack of responses. What distro is it running? Is this something you built/compiled yourself?
    I am currently running the images built by Crossbow
    PlatformX with Stargate
    They call it release 7.3

    I may have to rebuild source with arm-gcc to get ppp functionality, I am still looking into that. On a side note, I got DSA authentication working but it is still a no go for RSA.

    thanks,
    Zack

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •