Find the answer to your Linux question:
Results 1 to 4 of 4
I just recently installed Mandrake 10 on my system. Everything went well on the installation but when I booted my computer it would not boot if the wireless adapter(A Microsoft ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3

    Linux-Wlan Wireless Adapter Problem(Prism2 USB)


    I just recently installed Mandrake 10 on my system. Everything went well on the installation but when I booted my computer it would not boot if the wireless adapter(A Microsoft USB Adapter MN-510 using the Prism2 chipset) was connected. After some research I found out I needed to use the Linux-Wlan-ng drivers. I downloaded version 0.2.1pre21 and installed it. I got it to install after I configured my kernel(to get the source tree all set up) I didn't install the configured kernel(I just ran Make oldconfig and then make) Ok installation of the drivers went perfectly and after that I was able to boot my PC with the adapter connected(I take it thats a good sign). But I still can't go on the internet. When I ran Modprobe for the Prism2_usb drivers and got this:

    Code:
    [root@localhost sebastian]# modprobe prism2_usb
    FATAL: Error inserting prism2_usb (/lib/modules/2.6.3-7mdk/linux-wlan-ng/prism2_usb.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    dmesg came up with this:

    Code:
    prism2_usb: disagrees about version of symbol p80211netdev_rx
    prism2_usb: Unknown symbol p80211netdev_rx
    prism2_usb: disagrees about version of symbol register_wlandev
    prism2_usb: Unknown symbol register_wlandev
    prism2_usb: disagrees about version of symbol wlan_unsetup
    prism2_usb: Unknown symbol wlan_unsetup
    prism2_usb: disagrees about version of symbol unregister_wlandev
    prism2_usb: Unknown symbol unregister_wlandev
    prism2_usb: disagrees about version of symbol p80211netdev_hwremoved
    prism2_usb: Unknown symbol p80211netdev_hwremoved
    prism2_usb: disagrees about version of symbol wlan_setup
    prism2_usb: Unknown symbol wlan_setup
    prism2_usb: disagrees about version of symbol p80211netdev_rx
    prism2_usb: Unknown symbol p80211netdev_rx
    prism2_usb: disagrees about version of symbol register_wlandev
    prism2_usb: Unknown symbol register_wlandev
    prism2_usb: disagrees about version of symbol wlan_unsetup
    prism2_usb: Unknown symbol wlan_unsetup
    prism2_usb: disagrees about version of symbol unregister_wlandev
    prism2_usb: Unknown symbol unregister_wlandev
    prism2_usb: disagrees about version of symbol p80211netdev_hwremoved
    prism2_usb: Unknown symbol p80211netdev_hwremoved
    prism2_usb: disagrees about version of symbol wlan_setup
    prism2_usb: Unknown symbol wlan_setup
    Anyone know what is going on

    Thanks in advance

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3
    Someone said it might have something to do with the kernel not being in sync with my drivers. They adviced me to reinstall the kernel. Do you think thats the problem?

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Did you compile this driver on your system or did you download a pre-compiled binary? If you did compile it yourself, then that can't be the problem, while if you downloaded a binary driver, then that's most likely the problem.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3
    I compiled it miself. The problem is when I did Make Oldconfig and Make I didn't install the kernel. I think that maybe the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •