Find the answer to your Linux question:
Results 1 to 9 of 9
Hey, all. So far, I've been booting back and forth between Ubuntu 7.10 Gutsy (beta) and Windows XP Home for numerous reasons. One being that I have my Xbox connected ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    8

    Internet Connection Sharing


    Hey, all.

    So far, I've been booting back and forth between Ubuntu 7.10 Gutsy (beta) and Windows XP Home for numerous reasons. One being that I have my Xbox connected to my computer and this cute little thing in Windows called "Internet Connection Sharing" allows me to play on Xbox Live.

    But I'm ready to make the transition into making my computer 100% Linux with Windows running in VirtualBox.

    I need to find a way to connect my Xbox to the internet through my computer while running Linux.

    I have a very interesting configuration:

    Modem/ISP < Linksys WRT54G W/less router (192.168.1.1) < My Computer < DLink DI604 LAN Router (192.168.0.1) < Xbox

    In Windows, I have two network connections: my wireless connection (internet), and my LAN connection (router and game consoles).

    Here's how I make it work in Windows. I enable internet connection sharing on my wireless connection and leave it on DHCP. Then I set my LAN connection to static and set the IP and subnet to match my LAN router and leave the gateway blank (this is the only way I've gotten it to work). Then I disable my LAN router's DHCP (again, the only way I've gotten it to work), and set my xbox on a static IP (matching my LAN router) and set the gateway to be the same IP as my LAN IP on my computer.

    My wireless router directly forwards internet to my computer through DMZ.

    This allows unrestricted (and open NAT) access for my Xbox to the internet.

    I am completely lost as how to accomplish this in Linux. I tried bridging and all I managed to accomplish is royally screwing my internet connection to the point where I had to restore my backup /etc/nework/interfaces configuration.

    Can anyone help me with the information given? Any suggestions are appreciated with utmost gratitude.

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    31

    How to IP Foward

    Naetholix;
    I really need to think about this...

    Modem <--> W/less Router <--> Linux Box <--> Switch <--> Xbox

    Keep your wireless router configured to hand out dhcp leases, Your linux box will get the lease from it wirelessly. Plug your switch into the ethernet card on the Linux box. Configure ethernet /etc/sysconfig/network-scripts/ifcfg-eth0 for 192.168.0.1.

    At Prompt turn on IP Forwarding:

    echo 1 > /proc/sys/net/ipv4/ip_forward

    service network restart

    Assign the xbox a static IP Address, default route of 192.168.0.1, and add your DNS entries.

    Then try it out.

    If you want to make IP Forwarding permanent add the following to /etc/sysctl.conf

    # Controls IP packet forwarding
    net.ipv4.ip_forward = 1

    Bitstreamer

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    8
    This looks like promising advice, but I don't have a 'sysconfig' folder in my /etc directory; therefore, I don't believe this is much help at the moment.

    I am running the latest beta version of Ubuntu 7.10 Gutsy Gibbon, if that's any help.

    XD Yeah, I know: this is a stupid network to have in a house just for recreational stuff. But like I said, I got it to work with Windows. Anything you can do in Windows, you can do better in Linux, just with a little hard work.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    31
    ok, /etc/network/interfaces instead of /etc/sysconfig/network-scripts/ifcfg-eth0

    then restart your network, look in the /etc/init.d/ or /etc/rc.d/ for the "network" script. then do a ./network restart or from the anywhere network restart. I really don't know Ubuntu at all, but I'm sure it isn't much different.

    I believe the /proc/sys/net/ipv4/ip_forward file is still located in the same place.

  6. #5
    Just Joined!
    Join Date
    Feb 2007
    Posts
    8
    Still no luck. I tried changing around different network configurations as well, and nothing. I tried making everything on the network match an x.x.x.y IP to see if it would work, still nothing.

    Could it be a problem with my gateway on my NIC? Currently, I have eth0 set with no gateway, because that's the only way it would work in Windows. The gateway on my xbox is set to my NIC IP; gateway on my wlan0 is my internet-providing router IP.

  7. #6
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134

  8. #7
    Just Joined!
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    31
    Naetholix,

    On your Linux box, set your default gateway to the IP address of your wireless router.


    Bitstreamer

  9. #8
    Just Joined!
    Join Date
    Feb 2007
    Posts
    8
    Quote Originally Posted by bitstreamer View Post
    Naetholix,

    On your Linux box, set your default gateway to the IP address of your wireless router.


    Bitstreamer
    The gateway of my NIC? Because the gateway of my wifi card is already my router IP; but I'll give it a try, changing my NIC gateway to my w/less router.

    On the IPTables howto page, I've run into a few problems and I think it's because I'm running the newest version of ubuntu. It asks me to create a file in the /etc/rc.d directory. I don't have an rc.d dir, I have several (rc0.d, rc1.d ~ rc6.d, rcS.d) and I can't get anything to work whilst experimenting with each one.

  10. #9
    Just Joined!
    Join Date
    Feb 2007
    Posts
    8
    Ok, hey! I actually got it to work. Was following link after link and finally found this page:

    Ubuntu Server Guide - IP Masquerading

    Typed in the code listed there (and substituted wlan0 for ppp0) and got no error messages. Went to my Xbox 360 network settings, tested the Xbox Live connection, and it confirmed every test in there.

    Although, now, it lists my NAT as 'Moderate,' rather than 'Open.' This shouldn't be anything to do with my routers because it was Open when running WinXP (I'm using DMZ on both routers).

    But this is a huge breakthrough for me. Thanks to everyone who helped in any way! Much appreciated!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •