Find the answer to your Linux question:
Results 1 to 2 of 2
Hi I connect to internet by a insecure lan that have configure smoothwall, a firewall with proxy capacities that log all web and instant messaging traffic. I want to have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    2

    ssh tuneling - pidgin OK, Firefox NO


    Hi
    I connect to internet by a insecure lan that have configure smoothwall, a firewall with proxy capacities that log all web and instant messaging traffic.

    I want to have secure web browsing and IM use. For this, I configure a external ssh server (at my home) that is prepared to make ssh tunels for two things:
    1.- jumping blocking ports
    2.- Don't let to logging my web browsing and IM .

    For this, I use this command:

    ssh -N -l username -D 443 ip

    where

    username = username of my external server at home
    ip = ip of my external server at my home

    After this, I configure pidgin, each account (msn, gtalk, etc) to use a socks4 proxy, with the server = localhost and port = 443. At this way, pidgin exit by 443 port, where he find a ssh tunel that connect directly to my home, in a ssh encripted way. None any kind of server (except ssh server) need for this at home server. And this works great!

    I want to use the same tunnel to web browsing. I go to configure Preferences from firefox, and I configure the connection parameteres. I configure the proxy server, socks4, localhost, and port 443, the same like pidgin, but I can't browsing. There is no response at the firefox screen, none page is load.

    Is needed to install any service in my home server like squid? If I have to install squid or something similar, why is the reason that pidgin can connect through the ssh tunnel withou any kind of service?

    Can I use the same tunnel / port for the two apps (firefox and pidgin)?

    What's the problem here?

  2. #2
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Late reply, but this can be a good reference for other people.

    In order to browse with Firefox through ssh tunneling, I had to tunnel DNS traffic as well: in Firefox's address bar type about:config and look for network.proxy.socks_remote_dns, then set it to true.

    Hope it helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •