Find the answer to your Linux question:
Results 1 to 9 of 9
wow i never thought setting up linux could be so hard, i usally hate asking for help but i just cant seem to get my ethernet nic and my wifi ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6

    Setting up my NIC


    wow i never thought setting up linux could be so hard, i usally hate asking for help but i just cant seem to get my ethernet nic and my wifi card to work properly. My comp is a Sony VAIO I had red hat 9 installed and my ethernet worked but then i switched to 2.6.7 kernel and it wont work anymore. every time i try to go into the network config tool i get this message
    "eth0 has an alias to module sis900 in modules.conf instead of curently loaded module ip1394"

    The nic is a SiS 900/7016CI card so thats what it needs to be set to i guess but i cant seem to get rid of the ip1394 thing.

    I also would like to get my built in wifi card to work as well it is a lan-express card. i have no idea at all how to set it up. Under wireless network card i show nothing that resembles my card.

    I am VERY new to linux just been running it for about 3 days now so a little extra explanation would be great.

    Thanks for any and all help.

  2. #2
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Make sure your /etc/modules file doesn't have a line "ip1394". This file tells the computer what modules (module=a driver or other piece of code that can be dynamically added to or removed from the kernel's operation) to load at startup, and I don't think you need the module ip1394 since I think that's for IP via Firewire, and you have a Sony Vaio. So open up a text editor as root (the super-user) and open the file /etc/modules. Remove the line "ip1394" if there is one, and restart your machine.

    You can also use the command
    Code:
    rmmod ip1394
    as root to unload a loaded module, but if you don't stop it from loading at boot time then you'll have to do this every time you reboot.

    I hope this works out for you... and you better get over hating to ask for help. It's good to try as hard as you can to solve problems for yourself, but if you're going to become a competent Linux user, you're probably going to have to ask a lot of questions. :o Don't worry, we won't bite.
    Situations arise because of the weather,
    And no kinds of love are better than others.

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    hey thanks for the help it says that it doesnt exist in /proc/modules

    also in my modules.conf it show nothing for ip1394 all i have is

    alias usb-controler usb-ohci
    alias usb-controler ehci-hcd


    alias sound-slot-0 i810_audio
    post-install sound-slot-0 /bin/aumix-minimal -f /ect/.aumixrc -L >/dev/null 2>&1 ||:
    pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 ||:

    I also dont have sound or usb working but one thing at a time if i can get the network to work i wont have to use 2 computers for everything =o)

  4. #4
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    What are the contents of your /proc/modules file (the file that contains information about all the currently loaded modules)? And I think Redhat sometimes calls /etc/modules.conf /etc/conf.modules instead, so of that file exists, what are its contents?

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    This is the contents of my /proc/modules file i had to log in under 2.4 kernel to be able to use the internet so i could post this so i dont know if this changes with 2.6 kernel also i dont have a conf.modules.

    is there anyway to just disable all firewire i dont use that port so i wouldnt care



    orinoco_cs 5864 0 (autoclean) (unused)
    orinoco 36024 0 (autoclean) [orinoco_cs]
    hermes 8196 0 (autoclean) [orinoco_cs orinoco]
    sis900 16812 1 (autoclean)
    sd_mod 13516 0 (autoclean)
    i810_audio 27720 0 (autoclean)
    ac97_codec 13640 0 (autoclean) [i810_audio]
    soundcore 6404 2 (autoclean) [i810_audio]
    parport_pc 19076 1 (autoclean)
    lp 8996 0 (autoclean)
    parport 37056 1 (autoclean) [parport_pc lp]
    autofs 13268 0 (autoclean) (unused)
    ds 8680 2 [orinoco_cs]
    yenta_socket 13472 2
    pcmcia_core 57216 0 [orinoco_cs ds yenta_socket]
    ipt_REJECT 3928 6 (autoclean)
    iptable_filter 2412 1 (autoclean)
    ip_tables 15096 2 [ipt_REJECT iptable_filter]
    sg 36524 0 (autoclean)
    sr_mod 18136 0 (autoclean)
    ide-scsi 12208 0
    ide-cd 35708 0
    cdrom 33728 0 [sr_mod ide-cd]
    usb-storage 69332 0
    scsi_mod 107160 5 [sd_mod sg sr_mod ide-scsi usb-storage]
    keybdev 2944 0 (unused)
    mousedev 5492 1
    hid 22148 0 (unused)
    input 5856 0 [keybdev mousedev hid]
    usb-ohci 21480 0 (unused)
    usbcore 78784 1 [usb-storage hid usb-ohci]
    ext3 70784 1
    jbd 51892 1 [ext3]

  6. #6
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    ok it did chang ei just lookedat it with the 2.6 kernel and it shows a few things that may be the problem

    eth1394 -- live 0xe08ed00
    ohci1394 34788 -- live 0xe08a2000
    ieee1394 110064 -- live 0xe0890000

    i tried unloading the eth1394 with rmmod eth1394 and it gave me

    FATAL: Kernel does not have unload support

  7. #7
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    ok i got the ehternet nic to work!!!! thanks for the help you pointing me to that file helped alot.

    Any idea on how i get my wifi card to work right?


    thanks again for the help

  8. #8
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    I don't know how to set up wireless cards, but the topic has probably been covered a lot in the forums. Try going to Forum Search at the top of the page and typing in the name of your WiFi card. If you don't see anything, then keep posting on this thread, and tell us the name of the card and what steps you've taken to set it up so far.

    Also, no big deal, but you shouldn't post more than one message in a row; instead, you can edit your last message to reflect new information. Just a tip.

    Anyway, good luck with your wireless card, and let us know if we can help.

  9. #9
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    My appologies for the tripple post i got a bit excited.

    I tried the search before i posted and came up with nothing unfortunatly.
    My wifi card is described as LAN-Express AS IEEE 802.11g miniPCI Adapter.

    I have found other sites that say that this card requires a modified version of the orinoco driver but i cannot find out how to modify that file or where to get the modified driver from.

    I have also found people being able to use this card by just upgrading to kernel 2.6 which was the reason i switched but it didnt fix it for me.

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •