Find the answer to your Linux question:
Results 1 to 2 of 2
in my home network ssh <slackhost.slack.org> works fine to the other pc(this who has slackware installed).when i try from the other pc to ssh <suse> it says connection refused(port 22 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169

    opening ports


    in my home network ssh <slackhost.slack.org> works fine to the other pc(this who has slackware installed).when i try from the other pc to ssh <suse> it says connection refused(port 22 closed).
    i tried nmap frontend program and i get for the pc which uses suse :
    =========================================
    Starting nmap 3.55 (http://www.insecure.org/nmap/ ) at 2004-07-13 19:37 EEST
    Interesting Ports on susehost (192.168.0.1) :
    (The 65534 ports scanned but not shown below are in state :closed)
    PORT STATE SERVICE
    631/tcp open ipp
    Nmap run completed --1IP address (1 host up) scanned in 11.120.seconds
    ===========================================
    these information below are for the second pc(slackware based pc):
    ===========================================
    Starting nmap 3.55 (http://www.insecure.org/nmap/ ) at 2004-07-13 19:37 EEST
    Interesting Ports on slackware.slack.org (192.168.0.2) :
    (The 65531 ports scanned but not shown below are in state :closed)
    PORT STATE SERVICE
    22/tcp open ssh
    37/tcp open time
    113/tcp open auth
    6000/tcp open X11
    Nmap run completed --1IP address (1 host up) scanned in 11.120.seconds
    ============================================
    how can i have my ports open(ssh and ftp i want for my home network)
    i have tried firestarter firewall,and it freezes when i connect to internet.i tried to configure irewal with yast and nothing happened.i also tried

    Code:
    iptables -A INPUT -s slackhost.slack.org -d 192.168.0.1 -i eth0 -p tcp --syn --dport 22 -j ACCEPT
    in order to open port for (ssh services).
    although nothing happened.
    what do u suggest me to do?
    any help appreciated!
    Linux For Ever!

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    found what i should do....i opened yast and configured network services(inetd).now my server(which runs suse 9.1) runs properly.how can i activate ssh support?there is not a choice to enable in yast network services.
    any help appreciated!
    Linux For Ever!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •