Find the answer to your Linux question:
Results 1 to 2 of 2
Hi guys, Ive recently installed RH 7.3 one one of our two home computers. Much to the dismay of my parnter i havent been able to get shared internet working. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    1

    shared internet - cant ping (insert confusion)


    Hi guys,

    Ive recently installed RH 7.3 one one of our two home computers. Much to the dismay of my parnter i havent been able to get shared internet working. I dont know much about linux and am getting a little confused with the vast config files etc.

    If i tell you what i want can you help? For now i just want to be able to share the servers net connection with the client. The whole domainname and config in linux is getting me a bit sidetracked too. I dont really care what it is as long as they are connected to a workgroup Mythical.

    Where im at right now is, the server can use the internet fine with ppp0, and can ping the client by name and ip.

    The client cant access the internet, can ping the server by ip, but cant ping it by name.

    Server:
    Running Redhat 7.3
    Uses: Ethernet card (eth0) for network and modem (ppp0) for dialup internet
    Name: Xeres
    Internal IP: 192.168.0.1
    Netmask: 255.255.255.0

    Client:
    Running Win98
    Uses: Ethernet card for network
    Name: Jasper
    Workgroup: Mythical
    Internal IP: 192.168.0.2
    Netmask: 255.255.255.0

    Im sure there'll be more you need me to tell you. If we assume no other settings have been made, (the ones i made have probably been wrong) can you point me along from here?

    Hope you can help before the mrs screws my neck!

    lee

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    Jakarta - Indonesia
    Posts
    6
    in your linux server (Xeres)...
    you should type this command

    #command to forward the packet
    echo "1" > /proc/sys/net/ipv4/ip_forward

    #linux NAT
    iptables -t nat - A POSTROUTING -s 192.168.1.2 -j MASQUERADE

    then you also should set Client's gateway to your Linux Box (192.168.0.1)

    for enabling the internet domain names...
    you should set the DNS Search Order in Linux or in Client

    #set DNS Search Order in Linux
    echo "nameserver ip_dns_server" > /etc/resolv.conf

    ##set DNS in Win98
    start - control panel - network - lan connection, - properties - TCP/IP - Properties, under the Gateway, there is a DNS Setting... just fill the DNS, with your IP DNS Server

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •