Find the answer to your Linux question:
Results 1 to 6 of 6
Hi folks, Ubuntu 7.04 server amd64 I need to change hostname from; Code: ubuntu.satimis.com to: Code: mail.satimis.com Apart making changes on; 1) $ sudo postconf -e myhostname=mail.satimis.com $ cat /etc/postfix/main.cf ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814

    Question on changing hostname


    Hi folks,


    Ubuntu 7.04 server amd64


    I need to change hostname from;
    Code:
    ubuntu.satimis.com
    to:
    Code:
    mail.satimis.com

    Apart making changes on;

    1)
    $ sudo postconf -e myhostname=mail.satimis.com
    $ cat /etc/postfix/main.cf | grep myhostname
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    myhostname = mail.satimis.com
    $ sudo /etc/init.d/postfix restart
    Code:
     * Stopping Postfix Mail Transport Agent postfix                         [ OK ] 
     * Starting Postfix Mail Transport Agent postfix                         [ OK ]

    2)
    Edit /etc/hosts as;
    Code:
    127.0.0.1       localhost.localdomain   localhost
    192.168.0.10    mail.satimis.com        mail
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    Edit /etc/hostname as;
    Code:
    mail.satimis.com

    $ sudo newaliases
    $ sudo hostname mail.satimis.com
    Both w/o complaint


    $ uname -n
    mail.satimis.com
    $ hostname -a
    mail
    $ hostname -s
    mail
    $ hostname -d
    satimis.com
    $ hostname -f
    mail.satimis.com
    $ hostname
    mail.satimis.com
    $ hostname -i
    192.168.0.10
    $ hostname -y
    (none)


    I don't have /etc/sysconfig/network file and "sysconfig" directory


    Please advise any other files I need to edit as well. TIA


    B.R.
    satimis

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    Surely this is a question of DNS? If you point mail.satmis.com at your mail server, you can name the mail server whatever you like. In fact, it's surely more convenient to have a CNAME entry in your dns, pointing a 'mail' alias at your mail handling machine's real DNS name, so that if the machine falls over for any reason (or if it's down for maintenance for any length of time) you can just point the 'mail' CNAME somewhere else as needed?
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Quote Originally Posted by Roxoff View Post
    Surely this is a question of DNS? If you point mail.satmis.com at your mail server, you can name the mail server whatever you like. In fact, it's surely more convenient to have a CNAME entry in your dns, pointing a 'mail' alias at your mail handling machine's real DNS name, so that if the machine falls over for any reason (or if it's down for maintenance for any length of time) you can just point the 'mail' CNAME somewhere else as needed?
    Thanks for your advice.

    Here is cat /etc/resolve.conf;
    Code:
    nameserver 202.14.67.4
    nameserver 202.14.67.14
    satimis@#ubuntu
    202.14.67.4
    202.14.67.14

    are DNS of ISP.

    I think there is a mistake here. Whether delete "satimis@#ubuntu" and replace it with "mail.satimis.com"?


    I found following error;

    1)
    At booting on text scrolling;
    Code:
    Warning:unable to determin IP address of 
    'ubuntu_mail.satimis.com' error: no value servers 
    configured - Fatal error processing configuration file 
    '/etc/proftpd/proftpd.con   [fail]

    2)
    Login as satimis. On console, it prompt;
    Code:
    mail:~$
    Not
    Code:
    satimis@mail:~$

    3)
    $ dig satimis.com
    Code:
    ; <<>> DiG 9.3.4 <<>> satimis.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56433
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;satimis.com.                   IN      A
    
    ;; ANSWER SECTION:
    satimis.com.            3600    IN      A       220.232.213.178
    
    ;; AUTHORITY SECTION:
    satimis.com.            3600    IN      NS      ns43.domaincontrol.com.
    satimis.com.            3600    IN      NS      ns44.domaincontrol.com.
    
    ;; ADDITIONAL SECTION:
    ns43.domaincontrol.com. 2008    IN      A       208.109.78.180
    ns44.domaincontrol.com. 3341    IN      A       208.109.80.75
    
    ;; Query time: 240 msec
    ;; SERVER: 202.14.67.4#53(202.14.67.4)
    ;; WHEN: Mon Nov 12 22:36:20 2007
    ;; MSG SIZE  rcvd: 129
    
    satimis@#ubuntu

    Please advise how to fix the problem. TIA


    B.R.
    satimis

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    Your ISP needs to report the right IP address for the MX for the domain.

    Get them to set up you MX record for the domain to "mail.satmis.com.", and get them to set up a CNAME to point "mail.satmis.com." to "ubuntu.satmis.com.", and change your computer back. Then you only need to tell your mailserver that it's answering all mail for the 'satmis.com' domain, and that it needs to answer to the name 'mail' if necessary.
    Linux user #126863 - see http://linuxcounter.net/

  6. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Quote Originally Posted by Roxoff View Post
    Your ISP needs to report the right IP address for the MX for the domain.

    Get them to set up you MX record for the domain to "mail.satmis.com.", and get them to set up a CNAME to point "mail.satmis.com." to "ubuntu.satmis.com.", and change your computer back. Then you only need to tell your mailserver that it's answering all mail for the 'satmis.com' domain, and that it needs to answer to the name 'mail' if necessary.
    Whether you meant MX record on Registrar's site?

    I did it already.

    Sorry on my previous posting I made a mistake. "dig satimis.com" should be w/o "satimis@#ubuntu" displayed. It should be on console command prompt.

    On console it displays 2 lines
    Code:
    satimis@#ubuntu
    mail:~$
    It is quite strange.

    $ dig MX mail.satimis.com
    Code:
    ; <<>> DiG 9.3.4 <<>> MX mail.satimis.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57982
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.satimis.com.              IN      MX
    
    ;; ANSWER SECTION:
    mail.satimis.com.       3589    IN      CNAME   mail.satimis.com.
    
    ;; Query time: 20 msec
    ;; SERVER: 202.14.67.4#53(202.14.67.4)
    ;; WHEN: Tue Nov 13 00:31:11 2007
    ;; MSG SIZE  rcvd: 48
    satimis

  7. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    Looks like your DNS MX records are screwed up somewhere; maybe you should discuss this with your ISP, having mail.satmis.com point as a CNAME to mail.satmis.com just has email servers timing out rather than sending you mail.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •