Find the answer to your Linux question:
Results 1 to 8 of 8
in my home lan when i try Code: ssh 192.168.0.1 which is the other machines name (the first has 192.168.0.1 and the second 192.168.0.2) i get the message ssh_exchange_identification:Connection closed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169

    problem with ssh


    in my home lan when i try
    Code:
    ssh 192.168.0.1
    which is the other machines name (the first has 192.168.0.1 and the second 192.168.0.2) i get the message
    ssh_exchange_identification:Connection closed by remote host
    what should be wrong?
    waiting for ur help!
    Linux For Ever!

  2. #2
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Something is closing your ssh session, What dist are you using? Verify that Shorewall and iptables havent blocked something. Try to shutdown iptables and shorewall and see if it workes better from /etc/init.d....

    With iptables -L you can see if any chains are implemented on your system.
    Regards

    Andutt

  3. #3
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    i'm using suse 9.1 on the pc i try to connect via ssh.i'll tried those u said and nothing happened ....the problem wasn't solved.
    any other ideas?
    i also removed iptables with iptables -F....
    Linux For Ever!

  4. #4
    Just Joined!
    Join Date
    Jun 2004
    Location
    Leiria - Portugal
    Posts
    72

    .ssh/known_hosts

    Is your sshd running?

    Have you changed de IP addresses after previous connections?

    Se and clean your .ssh/known_hosts...

    Just a guess...

  5. #5
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    i haven't changed my ip's (for both pc's).and of course sshd is running ..i figured it out with
    Code:
    ps -elf|grep sshd
    do i have to edit some kind of files i found in /etc/ssh?
    this is how my /etc/ssh/ssh_config file looks like:
    # $OpenBSD: ssh_config,v 1.19 2003/08/13 08:46:31 markus Exp $

    # This is the ssh client system-wide configuration file. See
    # ssh_config(5) for more information. This file provides defaults for
    # users, and the values can be changed in per-user configuration files
    # or on the command line.

    # Configuration data is parsed as follows:
    # 1. command line options
    # 2. user-specific file
    # 3. system-wide file
    # Any configuration value is only changed the first time it is set.
    # Thus, host-specific definitions should be at the beginning of the
    # configuration file, and defaults at the end.

    # Site-wide defaults for various options

    Host *
    # ForwardAgent no
    # ForwardX11 no

    # If you do not trust your remote host (or its administrator), you
    # should not forward X11 connections to your local X11-display for
    # security reasons: Someone stealing the authentification data on the
    # remote side (the "spoofed" X-server by the remote sshd) can read your
    # keystrokes as you type, just like any other X11 client could do.
    # Set this to "no" here for global effect or in your own ~/.ssh/config
    # file if you want to have the remote X11 authentification data to
    # expire after two minutes after remote login.
    #ForwardX11Trusted no


    # RhostsRSAAuthentication no
    # RSAAuthentication yes
    # PasswordAuthentication yes
    # HostbasedAuthentication no
    # BatchMode no
    # CheckHostIP yes
    # AddressFamily any
    # ConnectTimeout 0
    # StrictHostKeyChecking ask
    # IdentityFile ~/.ssh/identity
    # IdentityFile ~/.ssh/id_rsa
    # IdentityFile ~/.ssh/id_dsa
    # Port 22
    # Protocol 2,1
    # Cipher 3des
    # Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
    # EscapeChar ~
    # GSSAPIAuthentication no
    # GSSAPICleanupCredentials no

    # Set this to 'yes' to enable support for the deprecated 'gssapi' authentication
    # mechanism to OpenSSH 3.8p1. The newer 'gssapi-with-mic' mechanism is included
    # in this release. The use of 'gssapi' is deprecated due to the presence of
    # potential man-in-the-middle attacks, which 'gssapi-with-mic' is not susceptible to.
    # GSSAPIEnableMITMAttack no
    is there something wrong?
    Linux For Ever!

  6. #6
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    i tried everything but i don't know what is wrong.i disabled firewall but i don't know what else to do.
    please help!
    Linux For Ever!

  7. #7
    Just Joined!
    Join Date
    Nov 2004
    Posts
    1

    same problem here, someone please help

    i run gentoo kernel 2.4.26 recompiled
    no firewall whatsoever
    intstalled openssh latest release 3.9.1, i get the exact error when i ssh to it

  8. #8
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    if you are trying to ssh as root, you need to turn that option on in /etc/ssh/sshd_config

    there is a great manpage on sshd's config..
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •