Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I have recently updated my linux desktop edition computer to 7.04 from 6.04 with disastrous results. Well ok not disastrous results but things stopped working. One of these things ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    2

    Exclamation Lost in a linux network port enroute to squid proxy


    Hi,
    I have recently updated my linux desktop edition computer to 7.04 from 6.04 with disastrous results. Well ok not disastrous results but things stopped working. One of these things was Squid proxy server. The computer in questiion acts as a file server for 14 to 24 computers in a small school network. My Squid script was working fine in 6.04 but something has changed in the linux settings that I cannot find. The squid service itself is running (I think) but the client computer's web browsers just keep coming up as 'Proxy server is refusing connections'.

    Could some of the ports have changed under this new version and therefore my squid conf file would be wrong??
    If so how can I find the new ports to update my squid conf. file or how can I open up the old ones?

    The port settings in my squid.conf file are as follows
    Http_port 3128
    icp_port 3130
    htcp_port 4827
    www_ports 80 443
    ftp_port 21

    Feel free to ask anymore questions that might enable you to help me. Any suggestions are more than welcome.
    thanks in advance,
    John Calder.

  2. #2
    Just Joined!
    Join Date
    Nov 2007
    Location
    Camp Pendleton
    Posts
    55
    If the upgrade changed the config file, there should be a squid.conf.debconf-backup or something similar. Do you see any significant changes there?

  3. #3
    Just Joined!
    Join Date
    Nov 2007
    Posts
    2

    Lost in a linux network port enroute to squid proxy

    Hi thanks for your idea.
    I found the problem. the config page had not changed but for some reason the new version of linux did not like the 'acl_localhost' rule in the squid config file so therefore had a fatal error and could not start when i ran the service in the terminal. I removed the acl_localhost rule and its allowance statement from the config as I dont particularly need to worry about that type of security on my network. The config file worked fine after that and squid functioned just as before the update.
    Cheerz for your response,
    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •