Find the answer to your Linux question:
Results 1 to 3 of 3
I have a linux firewall which has a network card, eth1 that insists the link is down, despite having a link light on the card itself. I have used ethtool ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225

    eth1 not detecting link, despite NIC link light


    I have a linux firewall which has a network card, eth1 that insists the link is down, despite having a link light on the card itself. I have used ethtool to check and the result is as follows:
    Code:
    # ./ethtool eth1
    Settings for eth1:
            Supported ports: [ TP MII ]
            Supported link modes:   10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
            Advertised auto-negotiation: Yes
            Speed: 10Mb/s
            Duplex: Half
            Port: MII
            PHYAD: 1
            Transceiver: internal
            Auto-negotiation: on
            Current message level: 0x000020c1 (8385)
            Link detected: no
    There is a statically assigned ip address and the cable is definitely plugged into the NIC and the other end into the switch. There is even data activity light blinking, but linux still doesn't see the link.
    Code:
    # ifconfig eth1
    eth1      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
              inet addr:x.x.x.x  Bcast:x.x.x.x  Mask:x.x.x.x
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:867 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:36414 (35.5 Kb)
              Interrupt:4
    So the link does not appear up, despite what the hardware says. The kernel definitely detects the card, otherwise there would be no eth1. I can ping the eth1 ip address from the box itself but not from anywhere else on the network, and nor can the box ping anything anywhere else.

    It looks like it is not receiving any packets at all. I have changed switch ports, the cable, and used a second switch. Both switches have other devices working on them.

    I have changed network cards, pci slots, rebooted several times etc.

    This was working fine with the original network card and the ip address up until yesterday when there was a power failure and the machine went down hard. I am leaning towards broken hardware, but I've changed the NIC, the switch, the cable and used different pci slots. There is another network card in the box which still works... but I need two interfaces since it's a firewall.


    I am truly stuck. Any ideas?
    The Human Equation:

    value(geeks) > value(mundanes)

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,809
    I can only make a few suggestions.

    - Try the 'broken' NIC in another machine, test it to see if it's working, also try it on another switch if possible.

    - Check the lan cable on another switch/computer to ensure that it is working.

    - Check your internet connection isn't down (if this is the interface to you internet router).

    - Double chec the static IP assignements; with a power outage, maybe the network config got zapped, and it's got the wrong addresses in the config files?
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225
    1. I've tried 2 NICs. I've even tried them in different pci slots on the mobo.

    2. I've tried 2 cat 5e cables. I've tried 2 switches. I've tried different ports on the 2 switches.

    3. The internet is up, this is a separate box for another function.

    4. The static IP is correct
    The Human Equation:

    value(geeks) > value(mundanes)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •