Find the answer to your Linux question:
Results 1 to 6 of 6
Hey, I'm trying to troubleshoot why my desktop PC's LAN connection specifically on 100 mb/s speed (full duplex, autoneg on) is now unstable specifically in my dorm room on the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Location
    New York
    Posts
    3

    100 mb/s connection unstable after HD move, but 10 mb/s is stable


    Hey,
    I'm trying to troubleshoot why my desktop PC's LAN connection specifically on 100 mb/s speed (full duplex, autoneg on) is now unstable specifically in my dorm room on the college network. It can download files fine, but web pages will literally take forever to load and games that require an internet connection will not recognize any input.

    My connection started doing this when I tried to put a second IDE hard drive into my PC (I had to unplug and replug the power/IDE cables to my primary HD and the power plug to my video card to make room)...I immediately took it out afterwards and the terrible connection remained. It doesn't make any sense to me why this would've screwed up my connection, but I've narrowed the problem down pretty far now:

    -The port and the cable were tested and are fine.
    -My hard drive was reformatted so that's fine.
    -My internet connection was fine when I brought my PC to my friend's house and tested it there.
    -My account to log into the college network was tested on other PC's and is fine.

    The funny thing is when I change the speed to 10 mb/s, autoneg off, full duplex mode via the command "sudo mii-tool -F 10baseT-FD" the connection is stable and I am able to browse websites normally and play games online with no issues. But the speed for downloading individual files is slow now, and that's why I need to fix my 100 mb/s connection.

    Here are my default settings (gives the unstable connection) to which I switch to via "sudo mii-tool -R":
    Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: g
    Current message level: 0x00000007 (7)
    Link detected: yes

    The IP address is correct and IPV6 is disabled.
    The school's network is working fine for everybody else.

  2. #2
    Linux Enthusiast
    Join Date
    Aug 2006
    Location
    Portsmouth, UK
    Posts
    539
    Try it with auto negoatiation turned off.

    Alos have a look at the output from ifconfig, specifically errors, dropped and overruns.

    On a good network those values should all be 0.
    RHCE #100-015-395
    Please don't PM me with questions as no reply may offend, that's what the forums are for.

  3. #3
    Just Joined!
    Join Date
    Nov 2007
    Location
    New York
    Posts
    3
    Turning autoneg off or changing the duplex has no effect as long as the speed is set to 100 mb/s.

    Here's my ifconfig:

    eth0 Link encap:Ethernet HWaddr 00:07:E9:5B:AC:98
    inet addr:192.168.22.14 Bcast:192.168.31.255 Mask:255.255.240.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:60849 errors:786 dropped:0 overruns:0 frame:786
    TX packets:3298 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:10977550 (10.4 MB) TX bytes:657407 (641.9 KB)

    Any other ideas?

  4. #4
    Linux Enthusiast
    Join Date
    Aug 2006
    Location
    Portsmouth, UK
    Posts
    539
    Right what I noticed straight away were the frame errors (checksum)

    Code:
    RX packets:60849 errors:786 dropped:0 overruns:0 frame:786
    TX packets:3298 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000 
    RX bytes:10977550 (10.4 MB) TX bytes:657407 (641.9 KB)
    Compare that to the same stats on my home server, no errors in close to 24GiB of data transfered:

    Code:
    -eth0-
    RX packets:18368976 errors:0 dropped:0 overruns:0 frame:0
    TX packets:12660738 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:25223477794 (23.4 GiB)  TX bytes:969332436 (924.4 MiB)
    Interrupt:17 Base address:0x4f00
    
    -eth1-
    RX packets:7161882 errors:0 dropped:0 overruns:0 frame:0
    TX packets:19057013 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:607553493 (579.4 MiB)  TX bytes:25496014290 (23.7 GiB)
    Found this buried in a bunch of other stuff while I was trawling:

    If you have *any* frame errors, something is broken.
    Furthermore, since the frame error is based on a checksum that gets recomputed at each hop, something is broken between you and your nearest
    switch.

    In my experience the cheap consumer-grade "workgroup" switches are notorious for these problems. I used to have a stack of linksys switches that did this. Some testing indicated they'd work fine for 5 minutes, then start to
    throw frame errors on 1% of packets, which is enough to trash NFS traffic which goes over UDP. This is because it doesn't realize a file transfer has failed right away, and then has to retransmit the entire file (which would probably fail again...).
    RHCE #100-015-395
    Please don't PM me with questions as no reply may offend, that's what the forums are for.

  5. #5
    Just Joined!
    Join Date
    Nov 2007
    Location
    New York
    Posts
    3
    Ahh I see now...thanks for your help, matonb.
    I guess I damaged my integrated network card when I opened up my PC? Would you recommend that I buy a new network card?

    Thanks again!

    -RP

  6. #6
    Linux Enthusiast
    Join Date
    Aug 2006
    Location
    Portsmouth, UK
    Posts
    539
    If you think there is a chance you may have damaged it why not I'm sure you can get one for like $10 right?

    And it never hurts to have a spare, you never know when you might need one
    RHCE #100-015-395
    Please don't PM me with questions as no reply may offend, that's what the forums are for.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •