Find the answer to your Linux question:
Results 1 to 3 of 3
I just rebooted this server. And when I try to start the sshdaemon I get: Code: PRNG is not seeded How can I fix this? Thanks. Cheers, Robin...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429

    After reboot sshd is dead?


    I just rebooted this server.
    And when I try to start the sshdaemon I get:
    Code:
    PRNG is not seeded
    How can I fix this?

    Thanks.

    Cheers,
    Robin
    New Users, please read this..
    Google first, then ask..

  2. #2
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Check the permissions for /dev/random and /dev/urandom, the should both be readable to everyone.

  3. #3
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    Ok, I rebooted again. Nothing. Updated udev (yea only that, I didnt update sshd) and well it just works again.. I dont have a /dev/random or urandom since its a OpenVZ system.
    Meaning were he can access the /dev/random devices but well they arnt there.. (does that make sence?)

    Well, now he wants me to enter a password...
    But I did set it up as a password less serverice.

    So, well I didnt change the key. But still. I get that I have to enter a password. I checked if the keys were Valid. and yea they were. (ofc since I am really lazy so Basicly they are the bloody same file.. (I run a Copy Deamon that I coded myself. It does cmp id_dsa with authorised keys. If they are diffrent it authorised_keys gets removed and id_dsa copys to auth*_keys so Basicly I knoe for sure 100% that the files are ok.))

    I get when I run with -vvv I get the following msgs that I think that are problems..

    Code:
    we send a public packet, wait for reply
    we did not send a packet, disable method
    Well, any ideas?

    Cheers,
    Robin


    Edit/Add:
    The servers /etc/ssh/sshd_config file has the following lines:

    Code:
    Protocol 2
    PremitRootLogin no
    MaxAuthTries 6
    RSAAuthentication yes
    PubkeyAuthentication yes
    AuthorizedKeyFile	.ssh/authorized_keys
    PasswordAuthentication no   <-- I enabled that I since Password Login should never occur!
    UsePAM no
    UseDNS no
    Subsystem sftp /usr/lib/misc/sftp-server
    X11Forwarding yes
    The Clients /etc/ssh/ssh_config file has the following lines:

    Code:
    RSAAuthentication yes
    IdentityFile ~/.ssh/id_dsa
    The clients ~/.ssh/id_dsa.pub file is like this:
    Code:
    ssh-dss AAAAB3<way more>lnCjg= _sxb@1
    The servers ~/.ssh/authorized_keys file is like this:
    Code:
    ssh-dss AAAAB3<way more>lnCjg= _sxb@1
    New Users, please read this..
    Google first, then ask..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •