Find the answer to your Linux question:
Results 1 to 6 of 6
I seem to have messed up with the host file and my comp takes a very long time to boot up. It pauses for a long time at the "Starting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    59

    Problem with the /etc/hosts file


    I seem to have messed up with the host file and my comp takes a very long time to boot up. It pauses for a long time at the "Starting E-mail Transport" before booting up to the login screen.

    The file now contains :
    127.0.0.1 localhost.localdomain localhost
    <MY IP ADD> zeus

    Please let me know what should be the syntax and the contents of the first line so that it boots up normally

    Thanks

  2. #2
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    463
    Hi Kris. Here's my hosts file. I use Fedora 8. Should be pretty much the same.
    Code:
    [glenn@toshiba ~]$ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost       localhost
    ::1     localhost6.localdomain6 localhost6
    Glenn
    Powered by Fedora

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    59
    Thanks for the help. It still waits for a long time at the same point, where it is trying to start the sendmail daemon. Any idea what I can do it fix this problem?
    Also, just out of curiosity, what does the second line in your quoted text stand for?

  4. #4
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    463
    Quote Originally Posted by kris.c View Post
    Thanks for the help. It still waits for a long time at the same point, where it is trying to start the sendmail daemon. Any idea what I can do it fix this problem?
    What distro are you using? In Fedora you can stop sendmail by typing in a terminal /sbin/chkconfig --level 2345 sendmail off or you can do it through system-config-services.
    Quote Originally Posted by kris.c
    Also, just out of curiosity, what does the second line in your quoted text stand for?
    You got me there. Something to do with IPv6 ??
    Glenn
    Powered by Fedora

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    59
    That seems to do the job for now. I am using FC-6 on one machine and FC-4 on the other.. I had this problem on both of them

  6. #6
    Just Joined!
    Join Date
    Dec 2007
    Posts
    5
    it most likely is a dns resolution issue.

    possibly, your mail server is trying to resolve the fully qualified domain name of your system to an ip address and it cannot do so because there is no entry in /etc/hosts to enable it to do so. Try this: get the fully qualified domain name of your system (zeus.whatever.whatever) and add an entry in /etc/hosts to resolve that fully qualified domain name to your local ip address and restart the network services.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •