Find the answer to your Linux question:
Results 1 to 2 of 2
I've been having an occasional problem with a slackware-12 box running mysql where tcp connections (mysql, ssh, etc.) are getting reset for some unknown reason. For example, I have a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    5

    tcp/ip connection problems - frequent connection reset errors


    I've been having an occasional problem with a slackware-12 box running mysql where tcp connections (mysql, ssh, etc.) are getting reset for some unknown reason. For example, I have a suse box running apache web server that connects to the mysql server on the slackware box. Once or twice a day, and sometimes more, the connection drops and the suse box reports a 'connection reset by peer' error when connecting to the slackware box. This is not only true for mysql traffic but also for ssh.

    I did a tcpdump on the slackware box (on the mysql port only) for an hour that included the time when this connection reset occurred. When I ran a tcptrace, I found no obvious connection problems. All tcp connections logged were completed properly. I am attaching a zipped file containing the packet info in ascii format obtained from tcptrace. I would appreciate it if anybody can skim through it and see if they see any problem with segment or window sizes of the packets or whatever anamoly that you can find. A quick glance of the text file in the attachment reveals the throughput of slackware box (79333 Bps) is significantly higher than that of the suse box (4036 Bps) but no data losses.

    I also double checked the tcp configurations between the slackware and suse boxes. Most of them are same expect for slackware that seems to have some tcp_congestion_control values in /prov/sys/net/ipv4 that the suse box did not have. Also the syse box had tcp_syncookies set to 1 while the slackware had it set to 0. The tcp_mem value of the slackware box is also significantly higher. Slackware box has an additional variable called tcp_slow_start_after_idle set to 1.

    Any help on this is much appreciated. Both the slackware and suse boxes are on the same subnet.

    thanks in advance.
    nefertitian.
    Attached Files Attached Files

  2. #2
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    I can't say much and also had only a short look at the log file, but I remember that there is with the benchmark program iperf a condition where also a 'connection reset by peer' error appears that has also been reported on the net by others but no fix is available from the author.

    In that case there can be spotted actually a RST reset packet on the TCP level. I haven't tried to find out what causes the sending of this packet, I only could confirm that the peer reset comes with that packet.

    But in your log file I didn't see such a RST packet so I have no further hints.
    Bus Error: Passengers dumped. Hech gap yo'q.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •