Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I'm running Fedora core 6 and trying to set up nfs shares between my two machines. (192.168.1.2 and 192.168.1.12). The services look running well: [root@localhost ~]# rpcinfo -p 192.168.1.2 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    12

    NFS, trouble in setting up shares, newbie requires help


    Hello,
    I'm running Fedora core 6 and trying to set up nfs shares between my two machines.
    (192.168.1.2 and 192.168.1.12).
    The services look running well:

    [root@localhost ~]# rpcinfo -p 192.168.1.2
    program no_version protocole no_port
    100000 2 tcp 111 portmapper
    100000 2 udp 111 portmapper
    100024 1 udp 854 status
    100024 1 tcp 857 status
    100011 1 udp 806 rquotad
    100011 2 udp 806 rquotad
    100011 1 tcp 809 rquotad
    100011 2 tcp 809 rquotad
    100021 1 udp 32770 nlockmgr
    100021 3 udp 32770 nlockmgr
    100021 4 udp 32770 nlockmgr
    100003 2 udp 2049 nfs
    100003 3 udp 2049 nfs
    100003 4 udp 2049 nfs
    100021 1 tcp 52057 nlockmgr
    100021 3 tcp 52057 nlockmgr
    100021 4 tcp 52057 nlockmgr
    100003 2 tcp 2049 nfs
    100003 3 tcp 2049 nfs
    100003 4 tcp 2049 nfs
    100005 1 udp 840 mountd
    100005 1 tcp 843 mountd
    100005 2 udp 840 mountd
    100005 2 tcp 843 mountd
    100005 3 udp 840 mountd
    100005 3 tcp 843 mountd
    and

    [root@localhost ~]# rpcinfo -p 192.168.1.12
    program no_version protocole no_port
    100000 2 tcp 111 portmapper
    100000 2 udp 111 portmapper
    100024 1 udp 670 status
    100024 1 tcp 673 status
    100011 1 udp 944 rquotad
    100011 2 udp 944 rquotad
    100011 1 tcp 947 rquotad
    100011 2 tcp 947 rquotad
    100021 1 udp 32769 nlockmgr
    100021 3 udp 32769 nlockmgr
    100021 4 udp 32769 nlockmgr
    100003 2 udp 2049 nfs
    100003 3 udp 2049 nfs
    100003 4 udp 2049 nfs
    100021 1 tcp 37227 nlockmgr
    100021 3 tcp 37227 nlockmgr
    100021 4 tcp 37227 nlockmgr
    100003 2 tcp 2049 nfs
    100003 3 tcp 2049 nfs
    100003 4 tcp 2049 nfs
    100005 1 udp 983 mountd
    100005 1 tcp 986 mountd
    100005 2 udp 983 mountd
    100005 2 tcp 986 mountd
    100005 3 udp 983 mountd
    100005 3 tcp 986 mountd
    I've cobfigured the hosts.allow and hosts.deny:
    [root@localhost ~]# cat /etc/hosts.allow
    # hosts.allow This file describes the names of the hosts which are
    # allowed to use the local INET services, as decided
    # by the '/usr/sbin/tcpd' server.
    #
    portmap: 192.168.1.2
    lockd: 192.168.1.2
    mountd: 192.168.1.2
    rquotad: 192.168.1.2
    statd: 192.168.1.2

    [root@localhost ~]# cat /etc/hosts.deny
    #
    # hosts.deny This file describes the names of the hosts which are
    # *not* allowed to use the local INET services, as decided
    # by the '/usr/sbin/tcpd' server.
    #
    # The portmap line is redundant, but it is left to remind you that
    # the new secure portmap uses hosts.deny and hosts.allow. In particular
    # you should know that NFS uses portmap!
    portmap: ALL
    lockd : ALL
    mountd : ALL
    rquotad: ALL
    statd : ALL

    and correspondingly on the other machine.

    The exports:
    [root@localhost ~]# cat /etc/exports
    /home 198.192.1.2(rw,sync,insecure,no_subtree_check,nohi de)

    and correspondingly on the other machine.

    Here is my fstab:
    [root@localhost ~]# cat /etc/fstab
    LABEL=/ / ext3 defaults 1 1
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    /dev/VolGroup00/LogVol01 /home ext3 defaults 1 2
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/VolGroup00/LogVol00 swap swap defaults 0 0
    /dev/sda1 /media/sda1 vfat defaults,umask=0222 0 0
    /dev/sda5 /media/sda5 ntfs ro,defaults,umask=0222 0 0
    /dev/sda6 /media/sda6 ntfs ro,defaults,umask=0222 0 0
    /dev/VolGroup00/LogVol02 /home/ext ext3 defaults 1 2
    192.168.1.2:/ /home/salon nfs4 noauto,rw,user

    When trying to mount the last line I have the following message:
    [
    root@localhost ~]# mount 192.168.1.2:/
    mount: can't get address for localhost.localdomain

    I've disabled temporarily firewalls but it doesn't help.
    I don't find info on the net to go further.
    This newbie would be thankfull for some advise.

  2. #2
    Linux Enthusiast
    Join Date
    Aug 2006
    Location
    Portsmouth, UK
    Posts
    539
    Hi ifouane,

    [root@localhost ~]# mount 192.168.1.2:/
    mount: can't get address for localhost.localdomain
    Can you post the contents of /etc/hosts here

    can't get address for localhost is the first thing you need to sort out.
    RHCE #100-015-395
    Please don't PM me with questions as no reply may offend, that's what the forums are for.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •