I have cifs mounts defined in /etc/fstab that use a credentials file, I have been using this with smbfs on older distros and it all works fine so I simply changed the smbfs to cifs and hoped it would work.

Nope - error 13: permission denied.

After trawling the net I removed the spaces from my credentials file, still no joy. I have been fighting with it for hours and finally found the problem - the password contains characters that it doesn't like... );/? etc

If I change the user credentials to one with a nice normal password it all works fine. Unfortunately, changing the password or using a different account isn't really an option (for reasons which I won't bore you all with) so does anyone know of a way to make it work with the current password?

(It's definitely the password that is the problem, not the permissions on the account)