Find the answer to your Linux question:
Results 1 to 3 of 3
Like to get some help. I am configuring NIC teaming on Linux and having some problem. I did the following: 1) /etc/sysconfig/network-scripts/ifcfg-bond0 DEVICE=bond0 IPADDR=192.168.1.20 NETWORK=192.168.1.0 NETMASK=255.255.255.0 USERCTL=no BOOTPROTO=none ONBOOT=yes 2) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    2

    NIC teaming error


    Like to get some help. I am configuring NIC teaming on Linux and having some problem. I did the following:

    1)
    /etc/sysconfig/network-scripts/ifcfg-bond0

    DEVICE=bond0
    IPADDR=192.168.1.20
    NETWORK=192.168.1.0
    NETMASK=255.255.255.0
    USERCTL=no
    BOOTPROTO=none
    ONBOOT=yes

    2)
    /etc/sysconfig/network-scripts/ifcfg-eth0

    DEVICE=eth0
    USERCTL=no
    ONBOOT=yes
    MASTER=bond0
    SLAVE=yes
    BOOTPROTO=none

    3)
    /etc/sysconfig/network-scripts/ifcfg-eth1

    DEVICE=eth1
    USERCTL=no
    ONBOOT=yes
    MASTER=bond0
    SLAVE=yes
    BOOTPROTO=none

    4)
    /etc/modprobe.conf
    alias bond0 bonding
    options bond0 mode=active-backup miimon=100

    5)
    load the bonding module
    modprobe bonding

    6)
    Restart networking service
    service network restart


    However after I restart the network service, I have problem doing ping to other servers and from ping, there is many request time out.

    According to /etc/modprobe.conf, I put it to active-backup. But when I using less /proc/net/bonding/bond0 to verify the teaming, it still show me Bonding Mode: load balancing (round-robin).

    Is there any rpm I can use for teaming or any other setting I need to do?

    Apperciate the help. Thanks a lot.

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,746
    From the Linux NIC bonding doco:

    The available bonding driver parameters are listed below. If a parameter is not specified the default value is used. When initially configuring a bond, it is recommended "tail -f /var/log/messages" be run in a separate window to watch for bonding driver error messages.
    Take a look at /var/log/messages for any errors. Also, double check that your config is correct (for your Linux distro) and try specifying the mode on the command line when you load the bonding module.

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    2
    Quote Originally Posted by HROAdmin26 View Post
    From the Linux NIC bonding doco:



    Take a look at /var/log/messages for any errors. Also, double check that your config is correct (for your Linux distro) and try specifying the mode on the command line when you load the bonding module.
    Hi, may i know wat the command to use to specify the mode?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •