Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Hi all! Nice place. My computing experience began in 1992 with Apple IIes. I've used Macs (in school) and Windoze (starting with v3.1), but I've been considering Linux for a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Artesia's Avatar
    Join Date
    Feb 2008
    Location
    Southern California
    Posts
    85

    Smile Adventures in Linux


    Hi all! Nice place.

    My computing experience began in 1992 with Apple IIes. I've used Macs (in school) and Windoze (starting with v3.1), but I've been considering Linux for a couple years. I just bought a new laptop, and it came with Vista. Hello, world. It was officially time.

    The following is the sequence of events that has transpired thus far in my journey to make The Big Switch (first week in January).


    After many hours of reading, I decide on openSUSE with the KDE. The initial plan was to wipe my laptop and just go for it with a fresh install. But during my research I learn about dual-boot systems. I know what partitions are, but I've never administrated them.

    I find that Vista has a partition tool, so I use it to shrink Windows. Unfortunately, it only decides to give me 13 GB (there's over 80 GB available).

    Through more reading, I learn that 3rd party partitioning software can shrink this down more. I go looking for trial versions.

    I research, download, and install an app, only to find that the trial version won't perform this function. Two different apps, same thing. Uninstall. I'm not willing to pay $50 for this, and I'm tired of looking for cracks. This is one of the reasons I'm getting into Linux.

    I decide that I'll just use the 13 GB that Vista is allowing me, since it's plenty enough to install full SUSE. I can always format the whole thing later. This dual-boot thing will only be a temp setup until I feel comfortable with SUSE.

    I download the SUSE DVD iso and burn it. I install SUSE. This is painless and doesn't take all that long. It sees the partition that is ready and waiting for it and automatically settles in. And it's so pretty and non-windozy!

    SUSE installs GRUB, which handles the dual boot situation. On bootup, GRUB asks me which OS I want to use. Nice. I joyously jump into SUSE.

    I have two issues, both hardware related. Hardware issues is one of the gripes that make an appearance in the SUSE discussions, so I'm not hugely surprised. But also not too discouraged. One, even though I'm able to enter my monitor's aspect ratio (16:10), the only screen res options available to me are 4:3, the biggest one being 1152 X 864. So my screen is stretched, the fonts are fuzzy, and I'm lacking in screen real estate. All circles appear squashed. And circles tend to appear often. I want a real circle, dagnabbit! Two, the OS doesn't seem to recognize my wireless adapter. I spend hours trying to connect to my network, to no avail. Fortunately, connecting via ethernet is automatic.

    I spend an eternity trying to resolve the issues, sifting through blogs, forums, knowledge databases, and SUSE itself. I'm learning a lot in the process but it's not getting me anywhere with my problems.

    I finally get tired of this and decide that it's time to try another distro. I was pretty torn between Ubuntu and SUSE anyway, so let's go with Ubuntu. I liked KDE, but I'll try Gnome, since apparently it's better suited for Ubuntu than KDE.

    I download and burn Ubuntu 7.10. It's just a single CD? Cool.

    I figure that the best way to go about this is to format the partitions currently occupied by SUSE, so the space is once again unallocated and ready to receive Ubuntu. I go into the Disk Manager in Vista. There is no option to format these partitions, so I opt to delete them. Big, big mistake.

    I restart the machine. I must have destroyed GRUB, because I'm getting a GRUB error and neither OS wants to boot. My mind instantly flashes to the countless jokes about a blank screen with nothing but a blinking cursor. Yep, I have that.

    Well, maybe Ubuntu can solve the issue. I insert the Ubuntu 7.10 Gutsy CD and go. It's pretty. But the circles are not circles, goddammit!

    I poke around Ubuntu and I really like it! I also discover that what I'm using is a Live CD. I haven't actually installed the OS? Ah.

    I discover a menu under System Administration and see that there's a place to download hardware drivers that I need. For my monitor. Hallelujah! I do this. Unfortunately, implementation requires a system reboot and that doesn't exactly fly with a Live CD.

    I decide to install. What have I got to lose? I may have two operating systems on my machine, but neither one is loading.

    Install crashes Ubiquity. What the hell is Ubiquity? Back to the forums...

    So, it's a sad state of affairs. I can't load Vista, or SUSE, and Ubuntu doesn't want to install. I decide to try to put SUSE back on. Maybe it'll reinstall GRUB and at least I'll have some control again.

    I reinstall SUSE and the plan works. Both are loading fine, but of course this is no solution because I'm still having those problems in SUSE. But at least I have a functioning OS. That is, if you can call Vista a "functioning OS." haha.

    On top of these two, I try Ubuntu again. Perhaps if I format the SUSE partition as part of the Ubuntu install, I won't have the GRUB issue.

    I set the partitions with Ubuntu. I learn about root and ext3 partitions by trial and error. Unfortunately, the Ubiquity crashes are not resolved. More reading...

    It's really nice having a second, fully functioning computer on hand. One thing that prevented me from trying linux before was that I was scared to do these things to my one and only computer. I'm glad that I waited. I'm so smart.

    In a forum somewhere, I discover that entering a space in my name can cause Ubiquity to crash. Silly me, when Ubuntu asked "What is your name," I gave it my full name, spaces and all. I try again with a 'fmlast' format, the install goes through, AND it brought its own GRUB. Yay! I mean, major frelling Y.A.Y.

    As soon as install completes, it's volunteering that I need drivers (more yay) and updates. I jump at the driver first. I reboot.

    The first thing you see when the OS is loading is the round "working" indicator. And........ It's a circle!! YESSSSS!! It's a friggin circle!!!!

    I experience mild amusement at the fact that I have never in my life been happier to see a circle.

    I proceed with updates; all goes smoothly. I poke around some more and discover that I really like this. I still need to resolve the wireless issue, but I will resolve it.


    That's is for now. I am going to keep this setup for a while, until I get more proficient with linux. The main reason for keeping Vista for the time being is for a handful of Toshiba utilities that I don't have in Ubuntu, the wireless, and iPod control. The plan is to eventually wipe this laptop clean and go Ubuntu all the way. The headaches were well worth it, and I expected a steep learning curve when I began this project, anyway.

    It also occurs to me that I made this much harder than it needed to be. I decided to play with partitions and a dual-boot system. On a laptop, no less, when I know that laptops are notorious for highly specialized hardware. Had I installed Ubuntu (or SUSE, for that matter) on a clean desktop hdd, I probably wouldn't have experienced the problems that I did. Well, except maybe for the Ubiquity space-in-the-name install crash...


    And circles, circles are magnificent. There is a subtle grace and beauty in simple geometric shapes.

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    Welcome to the forums Artesia !

    Quote Originally Posted by Artesia View Post
    Through more reading, I learn that 3rd party partitioning software can shrink this down more. I go looking for trial versions.

    I research, download, and install an app, only to find that the trial version won't perform this function. Two different apps, same thing. Uninstall. I'm not willing to pay $50 for this, and I'm tired of looking for cracks. This is one of the reasons I'm getting into Linux.
    If you decide to play with partitions again I recommend you try the PartedMagic CD, its a quick download & easy to use.

    Sorry you initially had problems but glad to hear you are up and running. The alternate cd is ueful if you have problems with the live CD version of Ubuntu.

    I would not rush to get rid of the dual boot ... I've been dual booting for a couple of years. I very rarely use Windows now & never use it on the Internet.

    I'll look out for the squashed circles ... it's something I haven't noticed ... probably drive me mad now someone has pointed it out !

  3. #3
    Linux Newbie
    Join Date
    Jan 2008
    Location
    UK
    Posts
    211
    Welcome to the world of Linux.
    Linux makes computing fun again, don't you think?

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Hi Artesia and welcome!

    Let's get that wireless working! Is it an internal device? Open a terminal and do:
    Code:
    sudo lspci
    Then:
    Code:
    sudo lspci -n
    With your wired connection, post the results of the two commands here. Then we'll set to getting you connected.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #5
    Just Joined! Artesia's Avatar
    Join Date
    Feb 2008
    Location
    Southern California
    Posts
    85
    Wow, Dan, thank you so much for the offer! And thank you Jonathan and wowbag1 for the warm welcomes.

    Ok, here's the terminal results:

    jay@leo:~$ sudo lspci
    [sudo] password for jay:
    00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
    00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
    00:05.0 PCI bridge: ATI Technologies Inc Unknown device 7915
    00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
    00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
    00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
    00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
    00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
    00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
    00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
    00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
    00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
    00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
    00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
    00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
    00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
    00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    01:05.0 VGA compatible controller: ATI Technologies Inc Radeon X1200 Series
    11:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 01)
    17:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
    1d:04.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
    1d:04.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
    1d:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
    1d:04.3 Generic system peripheral [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
    jay@leo:~$ sudo lspci -n
    00:00.0 0600: 1002:7910
    00:01.0 0604: 1002:7912
    00:05.0 0604: 1002:7915
    00:06.0 0604: 1002:7916
    00:07.0 0604: 1002:7917
    00:12.0 0106: 1002:4380
    00:13.0 0c03: 1002:4387
    00:13.1 0c03: 1002:4388
    00:13.2 0c03: 1002:4389
    00:13.3 0c03: 1002:438a
    00:13.4 0c03: 1002:438b
    00:13.5 0c03: 1002:4386
    00:14.0 0c05: 1002:4385 (rev 14)
    00:14.1 0101: 1002:438c
    00:14.2 0403: 1002:4383
    00:14.3 0601: 1002:438d
    00:14.4 0604: 1002:4384
    00:18.0 0600: 1022:1100
    00:18.1 0600: 1022:1101
    00:18.2 0600: 1022:1102
    00:18.3 0600: 1022:1103
    01:05.0 0300: 1002:791f
    11:00.0 0200: 10ec:8136 (rev 01)
    17:00.0 0200: 168c:001c (rev 01)
    1d:04.0 0607: 104c:8039
    1d:04.1 0c00: 104c:803a
    1d:04.2 0180: 104c:803b
    1d:04.3 0805: 104c:803c



    And some other significant info...

    The Machine:
    Toshiba Satellite P205D-S7438

    The OS:
    Ubuntu 7.10, 64 bit, all up to date

    The wireless adapter:
    might be an Atheros AR5007EG instead of the AR5006EG that's listed above. In some forum somewhere, someone suggested to someone else that linux might be misidentifying it. This might be significant because the Device Manager on my Vista partition lists it as an AR5007EG.


    What I've tried so far:
    The most promising thing is a utility I installed which allows me to use Windows Drivers. Under System --> Administration --> Windows Wireless Drivers, I was able to install the inf file that I got from the driver I found here:
    ATHEROS Wireless LAN 2.4/5GHz - Download Driver AR5007EG

    The second from top, version 6.0.3.85, installed successfully. The Wireless Network Drivers utility lists Currently Installed Windows Drivers: "net5416 Hardware present: Yes." But when I click on Configure Network, it does not list a wireless network for me to configure--just the wired connection and the modem.

    I also read somewhere that I need to disable HAL because it will interfere. I did this; in System --> Administration --> Restricted Drivers Manager, Atheros HAL is unchecked and "Not in use."

    I've come across several threads with people asking this same question, and I'm ashamed to admit that entered some suggested commands into the terminal that I didn't quite understand what they were. I'm fairly certain that they were madwifi and ndiswrapper install and settings related. (Is the Windows Wireless Driver utiliy actually ndiswrapper?)

    Lastly, the laptop does have a manual wireless on-off switch, and it is in the on position.

  7. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    The madwifi driver works perfectly for me but I've seen where there have been problem like the ones you mention with your particular device and madwifi. I found this which may be worth looking into. For fun though, (who knows, we might get lucky) open a terminal and do in order:
    Code:
    sudo modprobe -r ndiswrapper
    Code:
    sudo modprobe ath_pci
    If there are no errors from the last command, do:
    Code:
    sudo iwlist ath0 scanning
    Do you see any access points?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #7
    Just Joined! Artesia's Avatar
    Join Date
    Feb 2008
    Location
    Southern California
    Posts
    85
    The first two commands only took me to the next command line--no errors.

    The third command produced this:

    ath0 Interface doesn't support scanning.


    I tried the driver suggested in the thread you linked to, but it wouldn't install. (I used the Wireless Network Drivers utility again.) I then removed the other driver I had in there, rebooted, and tried installing it again, but same result.

  9. #8
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630


    You've probably already seen this bug report which I've been reading over this morning. This is such a shame. The Atheros based sets I've used with Madwifi have always run so perfectly. It's a good thing you have a wired connection though. If after exhausting all avenues, (as it appears you are pretty close to doing), you might want to consider a PCMCIA card. Many are very reasonably priced, give good performance with ndiswrapper and provide better signal strength overall. If that is an option, perhaps a new thread asking Ubuntu users which PCMCIA cards they prefer with Gusty will yield an abundance of recommendations.

    I'm sorry I couldn't help.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  10. #9
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    At worst you can usually swap out the network cards, they are in the mini-pci-x format. It'd be better not to have to. They can be replaced very easily and had cheap on eBay.

    Actually I have a broadcom 4311 (maybe 4312) which was shipped to me accidentally when I ordered an Intel card. You are more than welcome to it - it's almost unused and just taking up space on my shelf. It will work in 802.11B (11Mbps) with the open source drivers with firmware and works perfectly under ndiswrapper.

    Also, I'm moving this thread to networking. It'll be more at home there.

  11. #10
    Just Joined! Artesia's Avatar
    Join Date
    Feb 2008
    Location
    Southern California
    Posts
    85
    Dan, thanks for the link. Yes, I have come across that page, but to be honest most of it is WAY over my head. I really appreciate you spending your time trying to help. Even if there's no solution right now, hearing it from someone with your knowledge means a whole lot more than me wondering if it's the computer or my newbieness.

    bigtomrodney, that's very kind of you! There's a lot of documentation and instructions out there for both the 4311 and 4312, and apparently it's real simple with Ubuntu's restricted driver manager. I'm very interested! I have an ExpressCard slot (54mm). Is that what that's for? I was just about to start dismantling the bottom of the laptop when I discovered that.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •