Find the answer to your Linux question:
Results 1 to 5 of 5
I cant get internet working i think its my own stupidity can someone help. Im trying to get internet to my laptop A20m thinkpad. the internet in my apt. is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3

    Internet Prolbems


    I cant get internet working i think its my own stupidity can someone help.
    Im trying to get internet to my laptop A20m thinkpad. the internet in my apt. is set up as fallows. Isp is comcast (i live in federal way WA) cable internet runs into somthing they called a ?surfboard? then runs to a lynksys router all the comuters in the apt 1dell 2macs 1laptop run to the router internet works on everything except my laptop when i take the ethernet cable out of my laptop and plug it into the closest mac internet runs fine.
    so i dont think its a network issue. My etheernet card is intel ethernet express or somthing like that. the strange thing is when eth0 is up, which i couldent get to start on boot, i can ping the network and machines that are turned on connected to the network but i get about 50-70 percent packet loss with a 64mb packet. DHCP works beacuse it would automaticly find the correct DNS ip and everything elese it needed. i ran about every setup connection type that made sense but coud not get any internet. i took mandrake 10 off and installed redhat 9 and have the same prolbem (except eth0 starts at boot now) Please help!

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Location
    Leiria - Portugal
    Posts
    72

    It seems a hardware problem...

    Hi there,

    You can have a DNS resolution problem in your laptop.

    To test that you can try to ping an IP address of a known internet connected host, in ex. 129.42.20.99 (that is www.ibm.com). Doing that you must see icmp responses until you hit Ctrl + c (^C). If you get those responses you are connected to the internet and your problem is about the name resolution (DNS) on client side.

    If DNS is your problem you may edit your resolv.conf (usualy /etc/named.conf) and see if the nex two lines are in that file:

    nameserver <ip_of_your_isp_1st_name_server>
    nameserver <ip_of_your_isp_2nd_name_server>

    Try to see if your NIC and your cable are working fine.

    Please post more info...

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3
    thanks for your help but I still cannot get an internet connection. i tried to ping www.ibm.com using ping (ip address) and got 100% packet loss. i dont realy know how to check if my NIC card is ok. this is another strange thing the network in my apt is xxx.xxx.1.101 to xxx.xxx.1.104 i belive the router is xxx.xxx.1.1 if a another comp is on i can ping it and get 0% packet loss its just when i ping xxx.xxx.1.1 is when i get about half packet loss so i think it might be a firewall issue with the router. the cable is fine beacuse when i plug it into a nearby computer the internet works. im out of ideas.

  4. #4
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    you might need to set a default gateway. if your router is 192.168.0.1 then in /etc/conf.d/net:

    Code:
    # For setting the default gateway
    #
    gateway="eth0/192.168.0.1"
    Good luck
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3

    Problem solved

    it turned out to be the cable!!! just goes to show that one should not over look simple solutions!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •