Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Question [SOLVED] udev symlink to dev/modem not working

    I'm running xubuntu on an old 600mhz laptop.

    I have a agere winmodem and I downloaded and installed drivers for it and they work (I think). They create a /dev/ttySLTM0 link to my modem. The drivers also came with a udev file ltmodem.rules thats supposed to create a symlink <-? to /dev/modem. I added it to /etc/udev/rules.d and restarted udev... no /dev/modem. I restarted the laptop... still no /dev/modem. /dev/ttySLTM0 is there though.

    Here's the ltmodem.rules file:
    # UDEV rule for ltmodem
    #  creates symlink /dev/modem to /dev/ttyLT?, and takes care of permissions
    KERNEL="ttyLTM[0-9]", NAME="&#37;k", MODE="0660", GROUP="dialout", SYMLINK="modem"

    Thanks for any help.

    EDIT: Holy something... I took one look at my post and my problem became obvious. The ltmodem.rules file searches for a ttyLTM0 when the drivers create a ttySLTM0\

    Thanks for this forum so I could see my mistake.
    Last edited by a10; 02-22-2008 at 03:08 AM. Reason: stupid overlooking

  2. #2
    Hmm I changed the ltmodem.rules file and restarted udev... Still no /dev/modem. I restarted the computer and still no luck. What else am I missing.

  3. #3
    still need answer?

    check udev rules filename has number like '10-ltmodem.rules'

    Here's the ltmodem.rules file:

    also, rule is not rite.


    # UDEV rule for ltmodem
    # creates symlink /dev/modem to /dev/ttyLT?, and takes care of permissions

    KERNEL="ttyLTM[0-9]", NAME="%k", MODE="0660", GROUP="dialout", SYMLINK="modem"
    is not rite.


    KERNEL=="ttyLTM[0-9]", NAME="%k", MODE="0660", GROUP="dialout", SYMLINK="modem"

  4. $spacer_open
  5. #4

    Thumbs up

    No I no longer need an answer. I now have the modem working just fine on the laptop. I should've posted the solution and ended the ambiguity in this topic.

    Anyways I gave up on the ltmodem driver. My biggest mistake was trying the ltmodem driver on a 2.6 kernel. OR maybe the mistake was putting a 2.6 kernel on a 600mhz laptop.

    I was able to get the modem working with martian_modem. All is fine now

    Thanks for your reply sex toy!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts