Find the answer to your Linux question:
Results 1 to 3 of 3
I have an Asus WL-107G which uses the rt2500 chipset. Linux recognizes the pcmcia card and has even assigned it an interface of wlan0. The laptop I'm using is an ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2

    [SOLVED] rt2500 on Mint


    I have an Asus WL-107G which uses the rt2500 chipset. Linux recognizes the pcmcia card and has even assigned it an interface of wlan0.

    The laptop I'm using is an IBM T41 which has a built in ipw2100 chipset. which has been assigned to int. eth1.

    I have a linksys wlan router hooked up in the room for testing.

    I test the interface by doing:
    Code:
    iwlist wlan0 scan
    And it does not find any wireless networks, however the same command using the ipw2100, eth1 int. will show the network.

    I have tried to rmmod rt2500 and then reinstall using modprobe using the newest drivers I found online, and the same thing...it can see the interface but it appears to not be working, I have tried placing the card in and out of managed and monitor mode...still nothing if i do
    Code:
    lsmod|grep rt
    it returns several different rt25xx drivers.

    Any ideas? For the record the same card, drivers and laptop work on slack... TIA

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    So what were these modules that were listed when you ran "lsmod | grep rt"? It could be that you may need to blacklist some of the drivers.

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2
    I figured this out. There were two different rt2500 modules, one was rt2500pci and the other was plain old rt2500. I modprobe -r both of them then modprobe rt2500 using the newest drivers I found online and it worked...

    Apparently Mint installs both of them, which I find odd because they negate each other


    Thanks for the reply though....

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •