Find the answer to your Linux question:
Results 1 to 3 of 3
I'm fairly new to linux but I'm trying to get a CentOS machine running. I have it installed, but I can't connect to the internet. No network. I have a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    4

    Finding the Network


    I'm fairly new to linux but I'm trying to get a CentOS machine running. I have it installed, but I can't connect to the internet. No network.

    I have a cable modem running through a linksys router. I've tried setting the Linux box up as a DHCP client - it fails. It doesn't find anything. I've tried setting it up with a static ip like 192.168.1.101 (255.255.255.0) and then setting the gateway to the router 192.168.1.1.

    I'm really lost. I don't know where to begin on how to troubleshoot this. Here is some extra info. If anyone can point me in the right direction, thank you.

    ifconfig shows:
    inet addr: 192.168.1.101
    Bcast: 192.168.1.255

    netstat -nr shows:
    Destination Gateway GenMask
    192.168.1.0 0.0.0.0 255.255.255.0
    169.254.0.0 0.0.0.0 255.255.0.0
    0.0.0.0 192.168.1.1 0.0.0.0

    Ping of router returns: Destination Host Unreachable

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,746
    Google: centos network config

    First Result

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    4
    Yeah, I got that far, but it's still not happening for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •