Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
You need to edit your gateway and DNS addresses. Can you enter 192.168.1.1 into the web browser. If this works you should get a logon for your router. If you ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77

    You need to edit your gateway and DNS addresses.

    Can you enter 192.168.1.1 into the web browser. If this works you should get a logon for your router. If you haven't setup a password or username for it,just try username = admin,password = admin.

    If it loads go to the status screen or browse around until you find information on your DNS servers. There should be 2 addresses. If you find these go to Mandrake contol center -> network & internet -> internet access and then type in your first DNS Server and then your second. Click OK.

    Now it's possible that because you have specified a gateway address that you PC cannot get past the router onto the internet.

    Open /etc/sysconfig/network in a terminal as root user:

    Code:
    vi /etc/sysconfig/network
    Then press ESC ,then I this should let you edit the file
    Then delete the gateway line and then quit and write the file.

    By Pressing ESC then :wq!

    Now reboot your PC and see what happens.

    Armage

  2. #12
    Just Joined!
    Join Date
    Aug 2004
    Posts
    9
    Ok, yes I can enter 192.168.1.1 into the browser, and it is already set up as the internet is working fine for all of the winxp computers on the network. I got the two dns addresses, and put them where you told me to. When I closed the window, and then opened the control panel to check on it, nothing had changed from before. No matter how many times i tried to change it , nothing changed once i exited.

    I decided I would then try the second suggestion. I opened the file fine , and deleted the line with gateway in it, but I must be doing something wrong because I can't figure out how to do the "wq" thing you mentioned. I hit escape, and type wq, nothing happens, try hitting enter, nothing happened. I'm not really sure what I am doing wrong with either of these things. Help!

  3. #13
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    When you have deleted the line Press ESC then colon then wq!. You will see the output at the pbttom left of the terminal screen.

    It should look like this

    Code:
    :wq!
    Then press enter.

    For your DNS addresses open the following file /etc/resolv.conf as root at the terminal.
    Then enter the following lines replacing the IP Addresses with your DNS IP addresses.

    nameserver 194.168.4.100
    nameserver 194.168.8.100

    Armage

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Aug 2004
    Posts
    9
    Got it working!

    What I did was follow your advice on changins the nameservers, but I then changed the gateway back to 192.168.1.1 and it works!

    Thanks VERY MUCH for the help!

  6. #15
    Just Joined!
    Join Date
    Aug 2004
    Posts
    9
    Well now i ran into another problem. The internet works now, but after around 10-15 minutes, it all of the sudden stops working. I go back and check the nameservers, and it only lists one and it is how it was before i changed it. I change it back again, and 10-15 minutes later it happens again. How can I prevent the file from changing itself?

  7. #16
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    I think DHCP is re-setting the nameserver addresses.

    If you search for a program called rp-pppoe, probably find it in google somewhere. It will override the nameserver settings so they won't change.

    I have never used it so, unfortunately don't know how it works exactly.

    Try it and post back results.

    Glad to hear the Internet is working to a certain degree.

    Armage

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •