Find the answer to your Linux question:
Results 1 to 8 of 8
I don't know what I did... but I used to have 2 network interfaces.... 1 was my IPv6 and one was IPv4.... Now, IPv4 is gone.... How do I get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    14

    Where'd my IPv4 interface go?


    I don't know what I did... but I used to have 2 network interfaces.... 1 was my IPv6 and one was IPv4.... Now, IPv4 is gone.... How do I get it back? Can I do some sort of repair with my install disk?

    I have eth0 and eth0:avahi listed in my devices tab in my network tools. But if I try to configure eth0:avahi, I get "The interface does not exist".

    Originally in network settings I had my dialup modem and 2 "wired connection" listed. Now I have just 1.

    Is there some way for me to just wipe my nic cards and start over? I'm within inches of reinstalling the whole shootin match.

    BTW, this is ubuntu 7.10 and I'm a complete noob.

  2. #2
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    682
    A single network device can happily have an IPv6 and IPv4 address at the same time.

    Code:
    root@angua:/media/sdb2# ifconfig eth1
    eth1      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
              inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::20e:35ff:fe32:2946/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:437797 errors:30 dropped:30 overruns:0 frame:0
              TX packets:260269 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:572839380 (546.3 MB)  TX bytes:45456291 (43.3 MB)
              Interrupt:11 Memory:e0204000-e0204fff
    To configure and IPv4 like this use the following.

    Code:
    sudo ifconfig eth1 192.168.1.5
    Because your card is listed as eth0 you'd have to change the command to use that instead of eth1 and you will have to change the IP to whatever is suitable for your network.

    Let us know how you get on,

    Chris...
    To be good, you must first be bad. "Newbie" is a rank, not a slight.

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    14
    Well... I tried that and no luck. Here's my concern. I used to have an eth1 listed (and still do in /etc/network/interfaces)... but it's not listed anywhere else.

    When I did the command you mentioned, nothing changed. I have DHCP on my network.... any ideas?

  4. #4
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    682
    what do you get if you try "ifconfig -a"?

    What kind of network card is it?

    Chris...
    To be good, you must first be bad. "Newbie" is a rank, not a slight.

  5. #5
    Just Joined!
    Join Date
    Apr 2008
    Posts
    14
    eth0 is listed... not eth1
    But eth0 is just showing a bunch of packets transmitted and none received.
    It's a cardbus card (notebook)... here's some more data lspci shows:
    CardBus bridge: Texas Instruments PCI1225 (rev 01) - This one is listed twice, it's a notebook btw
    Ethernet controller: Xircom Cardbus Ethernet 10/100 (rev 03)
    ----------------------------
    Some background on how I think this happened... I was trying to install synCE... they gave me the following commands:

    Unload the current modules:


    sudo rmmod rndis_host cdc_ether usbnet
    Now we have to delete the old drivers, such that the kernel will not reload them next time:


    sudo rm /lib/modules/`uname -r`/kernel/drivers/net/usb/{rndis_host,cdc_ether,usbnet}.ko
    Now we have to get and compile the new drivers:


    sudo apt-get install usb-rndis-source cdbs
    sudo module-assistant auto-install usb-rndis


    When I got to the last 2 commands, they failed. Presumably because I no longer had internet. (My internet comes thru a USB cable). I downloaded (on a separate machine) the cdbs file and uploaded it to the linux machine. My USB works now.... but the internet is still down.

  6. #6
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    682
    Sorry about the delay in getting back to you.

    Can I get you to run the following:

    Code:
    ls /lib/modules/`uname -r`/kernel/drivers/net/usb/{rndis_host,cdc_ether,usbnet}.ko
    and post the output so we can be sure that all of the modules you deleted were replaced.

    Chris...
    To be good, you must first be bad. "Newbie" is a rank, not a slight.

  7. #7
    Just Joined!
    Join Date
    Jun 2008
    Posts
    2
    you know, im really confused. im using ubuntu 7.04 and i remember the first time i installed it like 5 days ago it took 15 minutes and everything was working like a charm right away.. then i tried to upgrade to ubuntu 8 and it killed the computer.. would not boot anymore so i re-install ubuntu 7.04 (same CD same comp) but this time i have no internet!..

    i dont think i did anything different.. how come it was working the first time and second time, on a fresh install again, it doesnt get it...

    i see my router still has a lease for *ubuntu 192.168.0.103

    so i tried doing "sudo ifconfig eth0 192.168.0.103" and it kind of set the ifconfig info straight now i see a proper ip but still i cant connect to 192.168.0.1 in my browser....

    i also see that eth0:avahi in my network cards but it says it doesnt exist if i click edit on it.. eth0 is only showing ipv6 address but avahi shows a ipv4 address but its 169.x.x.x
    well actually that was before i write "sudo ifconfig eth0 192.168.0.103" cos now i only have eth0 and avahi is gone and eth0 has ipv4 and ipv6 ips.. but still it doesnt connect to 192.168.0.1 (my router)...

  8. #8
    Just Joined!
    Join Date
    Jun 2008
    Posts
    2
    when i go back on DHCP, the eth0:avahi reappears with 169.x.x.x ip address and the eth0 start having only ipv6 again..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •