Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21
eth0 Link encap:Ethernet HWaddr 00:40:2B:6A:B2:8B inet addr:198.162.0.2 Bcast:255.255.255.255 Mask:255.255.255.0 The private address you should be using is 192.168.XX.XX not 198.162.XX.XX . Also, if the XP box isn't providing DNS, set ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134

    eth0 Link encap:Ethernet HWaddr 00:40:2B:6A:B2:8B
    inet addr:198.162.0.2 Bcast:255.255.255.255 Mask:255.255.255.0
    The private address you should be using is 192.168.XX.XX
    not 198.162.XX.XX.

    Also, if the XP box isn't providing DNS, set the Linux system
    to use the name server of your ISP manually by editing
    /etc/resolv.conf

  2. #12
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    ; <<>> DiG 9.4.1-P1 <<>> Google
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

  3. #13
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    Quote Originally Posted by rcgreen View Post
    The private address you should be using is 192.168.XX.XX
    not 198.162.XX.XX.

    Also, if the XP box isn't providing DNS, set the Linux system
    to use the name server of your ISP manually by editing
    /etc/resolv.conf

    Thanks, I'll try that.

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    OMG! It works! Big Thanks to both of you!

  6. #15
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    well it looks like I spoke too soon. It only works when I am logged in as root. Any suggestions?

  7. #16
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    728
    Do you get the same unknown host error?

    Check the permissions on /etc/resovl.conf. On my computer it looks like this.

    Code:
    chris@angua:/etc/resolvconf/run$ ls -lL /etc/resolv.conf
    -rw-r--r-- 1 root dhcp 185 2008-04-28 17:53 /etc/resolv.conf
    If the permissions aren't then run the following as root:

    Code:
    chmod 644 /etc/resolv.conf
    If it's not the same error, or that doesn't fix it, post the output of a failing ping again.

    Let us know how you get on,

    Chris...
    To be good, you must first be bad. "Newbie" is a rank, not a slight.

  8. #17
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    I get unknown host on the ping and the web browser times out. I'll check the permissions. Thanks

  9. #18
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    Ok, I'm not sure if the file permissions did the trick or not, but I am able to browse now. (I'm on the Linux box now) I was not able to use the terminal command that you posted. I got an error message that said "Not a Directory" but I was able to change the permissions in the GUI. Also I changed a setting in Firefox from "Use system defaults" (for the proxy settings) to "Direct connection to the internet" It works but it is a little slow. My ping times are 50+ milliseconds and it takes about 5 - 10 seconds to lookup and start loading the page. But I happy for now. Thanks again for all your help.

  10. #19
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    Hello again. I was able to resolve my slow browsing problem by re-arraigning my DNS server list in resolv.conf. (I put the ISP's DNS servers above the 192.168.0.1) But now I have another problem. When I log in as root I can see all shares on my XP box and access all shared files and folders, but when I log in as a user I can see the XP box, but I cannot see or access the files or folders. I know it must be a permissions problem. So what file do I need to edit to fix this?

    Thanks again to everyone for the help.

  11. #20
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    728
    I'm going to have to pass on this one. I'd suggest starting a new thread so Samba specialist can take a look.

    Chris...
    To be good, you must first be bad. "Newbie" is a rank, not a slight.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •