Find the answer to your Linux question:
Results 1 to 7 of 7
I'm frustrated out of my wits trying to network my Windows XP machine with my Ubuntu Linux one. I'm going to illustrate this post liberally so that you can see ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Location
    Omaha, Nebraska
    Posts
    42

    pulling my hair out with Windows/Linux network


    I'm frustrated out of my wits trying to network my Windows XP machine with my Ubuntu Linux one. I'm going to illustrate this post liberally so that you can see what's going on.

    I have Samba installed. My Windows XP machine is a home-built one running with an Athlon 64 3700, 1.5 GB of RAM and two internal hard drives, a 250 GB one and a 300 GB one. I also have two 500 GB external drives, but I don't think they're relevant.

    My Linux PC is an HP Pentium III with an 18 GB internal drive (the original one) and another 60 GB one. Ubuntu 7.10 is installed on the 60 GB drive on an ext3 partition. The 18 GB one is the one I want to network with my Windows machine. I formatted it as an ext3 drive and installed a utility, IFS Drives, into XP to give it the ability to see Linux ext2 and ext3 drives. However, when I ran into trouble networking these PCs, I simplified. I converted the 18 gig into a FAT32 one. I wanted to use NTFS, but the partition editor wouldn't let me. So, that drive is FAT32 for now. I can always convert it back to ext3 when I finally get the network working.

    Actually, the network is partially working. I'm getting the Internet on both PCs. I ran a cat 5 from my cable modem and into a wired router and then ran another cat 5 from the router into the Windows machine. I then ran a cat 5 from the router into the Linux machine. Piece of cake. They both have Internet access.

    The problem is in getting them talking to one another. When I can copy files from the Windows XP machine to the 18 GB hard drive on the Linux machine, I'll be where I need to be.

    I have Samba installed on the Linux machine. So in that machine I go to System ==> Administration ==> Shared folders. I then choose the 18 gig drive from the menu in the path field.



    I name it "tomshared" in the properties dialogue and clear the read only check box.


    It then shows up as a shared folder named /home/tom.


    In General properties I give it the domain name musicbox.

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Location
    Omaha, Nebraska
    Posts
    42
    Part II

    I see that I have the choice of designating it as a Windows (SMB) share or a Unix (NFS) one. I choose Windows (SMB) because I figure that would be easiest for my Windows PC to work with. (When that doesn't work, I go back later and change it to Unix NFS, but still can't get sharing to work.)



    So now I move to the Win XP machine and run the networking wizard. Then I pull up the Windows File Explorer and go ==> Tools ==> Map Network Drive. Here's what I see:


    I see both PCs, cool. The Linux one is named Toms-jukebox and the Windows one is named Athlon_screamer. And here's where I'm stuck and frustrated out of my mind. I cannot access Toms-jukebox to save my life. I right click on Toms-jukebox and choose either Explore or Open. Either way I'm asked for my user name and password. The only user name I've ever used on the Linux machine is tom, and I've only used one password, which I know I have right because I've logged into the Ubuntu machine with it earlier. Nevertheless, I can't get in. I notice it changes my user name to include the name of the computer: TOMS-JUKEBOX\tom. I try to change it to be like the path on the Linux machine:TOMS-JUKEBOX\home\tom. No dice. I get this:


    If I right click on Toms-jukebox and choose Properties, it gives me an error message saying I do not have the appropriate access rights to the server. So then I cancel out of that dialogue and am back here:


    I don't have a drive letter for the Linux shared drive, so I choose none. I put in Toms-jukebox\musicbox and click finish, but am told the path cannot be found. I try everything else I can think of such as \home\tom, etc., but I can't get in. I also try selecting drive letters, but to no avail.

    I'm really pulling my hair out here. If anyone can shed some light on why this isn't working, I'd really appreciate it.

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    I'm in just about the same boat. I can get the sharing to work from Linux if I login as root, but not as a user. Also I can't get the sharing to work in Windows. Its ask for a UID and PW, but nothing works.

  4. #4
    Just Joined!
    Join Date
    Apr 2008
    Location
    Omaha, Nebraska
    Posts
    42
    Hey, Walt. We'll figure this thing out. I've been googling and altavistaing like crazy and I've found some helpful articles. The first two are about Windows/Linux networking with help from Samba. The third one is kind of a primer for Windows users to learn equivalents in Linux. It's helped me to understand things I didn't before.

    I can't log in as root because my distribution, Ubuntu, doesn't allow for that -- or at least that's true if I understand correctly.

    Right now I'm suspending working on the networking in favor of learning how to do a full backup of Amarok's data and all my music. I've put in A TON of effort organizing my music collection on my new Linux box, so much that it would be very painful if I lost it. Gonna get that figured out and then go back to the networking puzzle.

    Here are the links. Let me know if anything works. I'll share any breakthroughs I run across with you, and you do the same, okay?

    Quick and dirty Samba setup
    Linux.com :: Quick and dirty Samba setup

    Windows/Linux Networking
    Windows XP Login to Linux/Samba

    Windows to Linux: A Beginner's Guide
    Windows to Linux: A Beginner's Startup Guide - www.reallylinux.com *****

  5. #5
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,526
    Just to let you know that you can't by default log into Ubuntu as
    root, but when you are logged in you can use sudo <command> to
    execute a command that needs root.

    If you need to do many commands use sudo bash to open a root
    terminal.

    I have only managed to get samba shares partially working on
    the network in my office. I can log in OK, but other people can't!

    Those links may be very useful to me too
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  6. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Tom_Zecat, the first thing that occurs to me is hostnames. Your router will have both your Windows PC on the network and the Linux one too, but most routers do not offer a naming service and those that do can be hit or miss. I would imagine your Linux hostname is not being resolved. Try pinging the box from Windows and also check your Linux IP address and try using that in your connection string.

    Your naming should be something like
    Code:
    folder : 192.168.0.1\tomshared
    And your username would be
    Code:
    192.168.0.1\tom
    I see above you've confused the workgroup name with the sharename - don't use musicbox in the folder name.

  7. #7
    Linux User
    Join Date
    May 2008
    Location
    NYC, moved from KS & MO
    Posts
    251
    Tom_Zecat, I second bigtomrodney's opinion. You might also need to check your group name on your xp machine because I saw there are two networks there, "Mshome" and "Winlinhome", which are different to the domain/group name you gave to your samba server, meaning you will not be able to access the samba server without changing either samba's group name to "Mshome" or xp's group name to "musicbox". Just my 2 cents.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •