Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all I've been using the wonderful NSLU2 Linksys device with an old, cut-down build of Debian, and it's worked great as a Samba server (for those folks who are ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    3

    NSLU2/Debian refusing to play nice with ICS!


    Hi all

    I've been using the wonderful NSLU2 Linksys device with an old, cut-down build of Debian, and it's worked great as a Samba server (for those folks who are not aware of this device, it's a great low-power way to run a little server - see the piccy of the device here). Recently a Debian etch release was made for this device so I've taken the plunge and flashed it/installed it (and it was so easy even I could do it :D).

    One major thing I'm having trouble with is internet routing. I am sure I'd got this working before on ethernet, and I've tried every incompetent possibility to get this to work, but it's not wanting to work for me at all on wireless. Briefly my NSLU2 device (192.168.1.108) joins to a wireless hub (192.168.1.1) via ethernet and I access this via a Vista laptop (192.168.1.2) via wifi. I have a USB modem on my laptop, which I have shared in Vista (using Internet Connection Sharing). However pinging a pingable remote server (e.g. Google) on my NSLU2 comes back with no reply, and ditto if I ping the IP of that server on my NSLU2. I think the problem is therefore IP routing, not DNS.

    From the NSLU2 however I can ping both the router (via ethernet) and the laptop (ethernet -> wireless). My config files on the NSLU2 are:

    Code:
    cat /etc/networks
    #default                0.0.0.0
    #loopback       127.0.0.0
    #link-local     169.254.0.0
    localnet        192.168.1.0
    
    
    cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    #allow-hotplug eth0
    auto eth0
    
    # New stuff added to make it appear on a standard static IP
    #iface eth0 inet dhcp
    iface eth0 inet static
            address 192.168.1.108
            netmask 255.255.255.0
            gateway 192.168.1.1
            up route add default gw 192.168.1.2
            down route del default gw 192.168.1.2
    
    
    cat /etc/resolv.conf
    nameserver (IP here) # ISP DNS server
    nameserver (IP2 here) # And again
    nameserver 192.168.1.1
    search workgroup
    I confess to not knowing in detail what all the above directives do, but as I say I think I got it going before when I used just ethernet. I've even tried disabling all my Windows firewalls and that's not made a difference. What tools can I try on my NSLU2 to see where it's coming unstuck?

    Thanks all in advance!

    Edit: traceroute produces the following, don't know if it's helpful:

    Code:
    foobar:/etc# traceroute 192.168.1.1
    traceroute to 192.168.1.1 (192.168.1.1), 30 hops max, 40 byte packets
     1  router (192.168.1.1)  0.645 ms  2.985 ms  2.914 ms
    foobar:/etc# traceroute 192.168.1.2
    traceroute to 192.168.1.2 (192.168.1.2), 30 hops max, 40 byte packets
     1  beth (192.168.1.2)  3.182 ms  2.997 ms *
    foobar:/etc# traceroute 66.249.91.99
    traceroute to 66.249.91.99 (66.249.91.99), 30 hops max, 40 byte packets
     1  * * *
     2  * * *
     3  * * *
     4  * * *
     5  * * *
     6  * * *
     7  * * *
     8  * * *
     9  * * *
    10  * * *
    11  * * *

  2. #2
    Just Joined!
    Join Date
    May 2008
    Posts
    3
    Hi all. If anyone can give me even the briefest of help, I shall appreciate it. I have been persisting with this, and still have not made any progress. This very simple task is, I admit, rather wearing me down.

    Alternatively, if you know of a tool I can use on Debian to try to determine where the problem is (Linux server, router, Win machine) that would be great. I can then come back here with further information.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •