Hello frens!

I'm working on RHEL4 Update 6 ( kernel 2.6.9-67.ELsmp ) on IBM x3650 m/t 7979. On the system, bnx2 modules is working for NetXtreme Broadcom Ethernet Cards.

Network connectivity is also Ok from outside. But after reboot 3/4 times the connectivity goes down with the error message :-
bnx2: Chip reset did not complete
SIOCSIFFLAGS: Device or resource busy

If I reboot the server it use to work fine but again rebooting 3/4 times the same error comes with the ethernet card & conncetivity goes down.

The contents of file /etc/modprobe.conf is

alias eth0 bnx2
alias eth1 bnx2
alias eth2 tg3
alias scsi_hostadapter aacraid
alias scsi_hostadapter1 ata_piix
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
install bond0 /sbin/modprobe bonding -o bonding0 mode=1 miimon=100 multicast=1
install bond1 /sbin/modprobe bonding -o bonding1 mode=1 miimon=100 multicast=1

I also tried by removing bonding on ethernet cards but still same problem is going on.

Where is the problem? Is there is problem of module of ethernet card? or problem with hardware? something else? Please suggest me.

one thing more there is 7 IBM servers with above status & same error on multiple servers.

Santosh Kumar Sah
e-mail: santosh.sah@alliedindia.com
(RHCE)
New Delhi
INDIA.